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Hi! Are you new to Inkscape?

Learn more about Inkscape, an open source vector graphics editor, in this free,
community-created Beginners’ Guide:
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This guide is a living document. This means that it is actively being edited and contin-
uously being improved—and you can contribute!

If you find something that is confusing, wrong, or otherwise needs to be edited, let us
know!
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CHAPTER

ONE

WHEN DO YOU NEED INKSCAPE?

There are many image creation and manipulation software programs.

However, there are two main types of images:

• Raster or bitmap images are a majority of the digital images you generally en-
counter. Common examples are JPG, PNG, GIF, TIFF or BMP. Raster images are
the default output of everything from digital cameras to most graphics editing
software like Paint or Paintbrush. They are made up of pixels, which is to say a
grid of colored rectangular dots.

The advantage of raster graphics is that at high resolutions (lots of pixels in a
small area) you can have very fine control over color and shape; raster images
can contain millions of colors and look very realistic.

However, the major downside to raster images is that the more the images are
manipulated after creation, the more the quality declines. For instance, if you
create your image at one size, making it bigger can create jagged-looking edges
(“pixelation”), while shrinking it can lead to colors and shapes blurring into each
other.

• Vector images are created with vector graphics software (like Inkscape). While
Inkscape uses an internationally standardized format for two-dimensional vector
graphics (SVG), many other, sometimes proprietary, file formats for vector graph-
ics and their various applications (fonts, CAD, cartography, 3D modeling . . . ) ex-
ist. Instead of being made of dots, vector images are made of mathematically-
defined lines and curves.

Lines in a vector graphic can also be joined together to form larger objects, each
of which can be given their own style (colors, patterns, etc.).

Because all of the elements of the vector image are defined by mathematical for-
mulae and not by a grid of dots as in a raster image, sharpness is maintained
regardless of how much the image is enlarged. However large or small you make
it, the curves are simply recalculated and redrawn, without losing quality.

As a result, a single vector image can be used for different sizes of the final image
presentation. For example, the same image will look equally sharp and clear –
and have exactly the same colors and proportions – on both a business card and
a large poster.
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One downside is that, if used for “realistic” drawing, vector images can have a
too-clean, artificial look.

Depending on how you intend to use your image, either raster or vector graphics may
better suit your needs.

Inkscape is a program for creating and editing vector graphics.

It is the ideal tool for drawing logos and icons, creating (animatable) graphics for
websites, for composing posters and flyers, or for making patterns for use with cutting
machines and laser engravers.

It is also a good choice for drawing short comics, making art, building user interface
mockups and making or editing diagrams created by other software. People use it for
fun projects, such as map-making, creating birthday cards, painting on eggs, 2D game
graphics and for many, many more purposes.

Inkscape is not the ideal tool for some other purposes, but there exist very powerful
alternative free software programs which we recommend without reservations:

• Photo editing (raster graphics): Gimp

• Desktop publishing (multi-page documents, printing in CMYK color space):
Scribus

• CAD (parametrical construction, engineering): LibreCAD (2D)

• Painting (raster graphics): Krita

• 3D modeling (three-dimensional graphics): Blender

Here are some examples of the types of images and projects that can be made with
Inkscape:

1.1 Artwork and Comics

1.1. Artwork and Comics 7
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1.2 Clip art, Icons and Logos

1.2. Clip art, Icons and Logos 9
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1.3 Layout and Prototyping

1.3. Layout and Prototyping 10
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1.4 Technical Drawings and Diagrams
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1.5 Physical Objects
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CHAPTER

TWO

PROFESSIONAL SOFTWARE

Inkscape is powerful but doesn’t require a recent, high-end computer to be usable. It
has many drawing tools, filters, effects and patterns.

Many professionals use Inkscape for vector image editing. It fits easily into a design
workflow with open source or proprietary tools.

2.1 What am I allowed to do with it?

Inkscape is free and open source software (Wikipedia). It can be downloaded and
installed on Windows, Mac, and Linux. Copying, distribution, and modification of the
software are freely permitted. Inkscape can be used at work or at home, for profes-
sional or personal work. What you create with it is entirely yours, and you are free
to distribute, share it, sell it, however you’d like — or keep it to yourself! Except if
you used someone else’s work as a basis for yours, in which case this person is also a
co-author of the work.

2.2 How much does it cost?

Inkscape is gratis, that is, cost-free: you can download and install it as many times
as you want without paying either a fixed fee or a subscription, and give it away to
friends, provided you agree with the free software GNU General Public License (GPL).
The only investment you’ll need to make is to learn to use it and gain new skills.

You can also donate to allow the project volunteers to dedicate more time to it.
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CHAPTER

THREE

INSTALLING INKSCAPE ONWINDOWS

Inkscape is available for Microsoft Windows operating systems from XP up to Windows
10. There are two basic methods for installing Inkscape onto computers with a Windows
operating system. One method is downloading and installing directly from Inkscape and
the other is installing it from the Microsoft App store. A description of both methods is
presented here.

Attention: If you had previously installed Inkscape onto your computer, you will
need to uninstall that version before installing the new version.

3.1 Method 1: Downloading and installing directly from
Inkscape

1. Using a Web browser, go to the Inkscape website’s download page for Windows.
The site may redirect you automatically to the best download, as shown in the
below graphic. If no appropriate choices are available, click All Platforms in the
orange bar for all options for all operating systems. If you are unsure if you
need the 32-bit or 64-bit version, read the section about Identifying Your System
Architecture first.

15
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2. Select an installation method from the available choices (exe, msi, archive) and
wait for it to download. You should either see a window giving you the option to
save the file, or a pop-up appear in your web browser with the file’s name and a
timer stating how long until the download is complete.

3. Once the download is complete, either click on the file in the lower left corner
(Chrome) or the top right corner (Edge and Firefox) of your screen to start the
installation process. On Firefox, it’s hidden behind a blue circle. If need be, go to
your file explorer, open your downloads folder and select the file from there. It
should be the first file at the top of the folder.

3.1. Method 1: Downloading and installing directly from Inkscape 16
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OR

4. If you get a User Account Control pop-up from Windows similar to the following
one click “OK” and wait for the Inkscape installation program to start.

5. The installer will now start up and try to switch to your system language, if it is
set to anything other than English. Click Next on the following welcome screen.

6. On the Custom Setup screen you can select which features you want to install
or not install. In most cases the default options should provide all that the user
needs, so click Next.

3.1. Method 1: Downloading and installing directly from Inkscape 17
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To reset the selections so that all features are selected, click Reset.

To confirm if you have enough disk space to install the selected features, click
Disk Usage.

Leave the destination folder as C:\Program Files\Inkscape and click Next unless
you want Inkscape to be installed in a specific location on your computer.

(Optional step)

If you do want to install Inkscape in a specific location on your computer, click the
Browse button and in the resulting window either make a new folder for Inkscape
and select it or select the destination folder you want Inkscape to be installed to.

3.1. Method 1: Downloading and installing directly from Inkscape 18
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7. Once you click Install in the following screen, a progress bar will appear showing
the different components being installed.

8. After the installation is complete, click Finish.

3.1. Method 1: Downloading and installing directly from Inkscape 19
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An Inkscape shortcut will appear on your desktop and a new Inkscape folder will
appear in your programs list.

3.1. Method 1: Downloading and installing directly from Inkscape 20
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3.2 Method 2: Installing from the Microsoft App store

You can also install Inkscape onto your Windows computer from the Microsoft App
store. If you have the Windows 10 Education version this will be the only way you can
install Inkscape.

Note: You will need a Microsoft account to install apps from the Microsoft store. If
you already have an account, skip the following steps on how to make one.

1. To create a Microsoft account using a Web browser go to https://login.live.com/
and select Create one!.

2. On the following page enter in the email address or phone number that you would
like to link your Microsoft Account to and then click Next. There is also the option
to get a new email address from Microsoft.

Note: We will be using a preexisting email for this example but if you want
to create a new email the process for making a Microsoft email is pretty straight
forward.

3.2. Method 2: Installing from the Microsoft App store 22
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3. Enter a password that you wish to use with your new Microsoft account and click
Next.

4. Enter in your first and last name then click Next.

3.2. Method 2: Installing from the Microsoft App store 23
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5. Enter the country/region in which you live and your birthdate.

3.2. Method 2: Installing from the Microsoft App store 24
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6. Check the email you used to create the account and find the email from Microsoft.
Enter the code from the email into the web form and click Next.

3.2. Method 2: Installing from the Microsoft App store 25
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7. Enter your phone number and then click send code to receive the security code,
then click Next.

3.2. Method 2: Installing from the Microsoft App store 26
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8. On the following page verify that the information is correct and click Looks good!
and your Microsoft Account is ready for use.

3.2. Method 2: Installing from the Microsoft App store 27
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9. From the task bar at the bottom of your screen click the Microsoft Store icon or
enter ‘store’ into the search bar and select ‘Microsoft Store’ from the results.

OR

3.2. Method 2: Installing from the Microsoft App store 28
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10. Enter ‘Inkscape’ into the Microsoft Store search bar and select the ‘Inkscape’ App
option from the results.

3.2. Method 2: Installing from the Microsoft App store 29
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11. In the following windows, to install Inkscape click Install and then enter your
Microsoft account username and then password in the window that pops up.

3.2. Method 2: Installing from the Microsoft App store 30
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12. After signing into your Microsoft Account click Install and the installation will
begin.

Once the download and installation is complete click Inkscape. A descriptive blurb
for the application appears. Hover your mouse over it and click Open to begin
working with Inkscape.

3.2. Method 2: Installing from the Microsoft App store 31
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Congratulations! You have now installed Inkscape onto your Windows computer.

If you need further help, please visit the FAQ section for Windows specific problems on
the Inkscape website.

3.3 Identifying Your System Architecture

Before you can begin to download Inkscape, you must first know what type of operating
system (OS) you have, 32-bit or 64-bit. If you already know what type of operating
system you have please skip this section and go the section on downloading Inkscape.

3.3. Identifying Your System Architecture 32
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3.4 Method 1: Using Keyboard Shortcuts

1. Press Win + R to open the Windows Run dialog.

2. Type “msinfo32” and press Enter.

3. Toward the middle of the window, you should see an option that says System Type.
Write down the associated information.

You will need this to select the correct Inkscape download file for your system.

3.5 Method 2: Using the mouse

1. Click on the magnifying glass or right-click Win and select Search to open a search
dialog and type ‘system’.

3.4. Method 1: Using Keyboard Shortcuts 33
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2. Click to open the System Information window.

3. Depending on the version of MS Windows on your computer, you will see a win-
dow like the one shown below. Towards the middle of the window, you should
see an option that says System Type. Write down the associated information.

You will need this to select the correct Inkscape download file for your system.

3.5. Method 2: Using the mouse 34
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CHAPTER

FOUR

INSTALLING INKSCAPE ON AMAC

4.1 Installing Inkscape from the Inkscape website

This is the recommended method for macOS users to install Inkscape.

1. Using a web browser, go to the Inkscape downloads page.

2. Click the box labelled macOS to find a list of downloads for macOS.

3. Depending upon the processor architecture of your Apple computer, choose the
appropriate Inkscape disk image (DMG) file for your system now. For the older,
Intel-based, Apple computers, choose dmg (Intel), and for the newer, Arm64-
based Apple computers, choose dmg (arm64).

36
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4. Once the download has finished, open your Downloads folder in the Finder. You
can open this folder by selecting Go → Downloads from the menu bar in the Finder.
Double-click the Inkscape DMG file to open it.

5. Click and drag the Inkscape icon to the Applications icon as instructed in this
window. This will install Inkscape on your Mac.

4.1. Installing Inkscape from the Inkscape website 37
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6. Open Inkscape by double-clicking its icon in the Applications folder. You can open
the Applications folder by selecting Go → Applications from the menu bar in the
Finder.

4.1. Installing Inkscape from the Inkscape website 38
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4.2 Installing Inkscape on OS X 10.7 - 10.10

If you have an older Mac running OS X version 10.7 - 10.10, you can still install an
older version of Inkscape, v 0.92. As part of this process, you will first install a helper
program called XQuartz and then Inkscape 0.92 itself.

4.2.1 Step 1: Install XQuartz

1. Using a web browser, go to the XQuartz website and click the XQuartz DMG icon
to download it.

2. Once the download has finished, open your Downloads folder in the Finder. You
can open this folder by selecting Go → Downloads from the menu bar in the Finder.
Double-click the XQuartz.dmg file to open it.

3. A new window will appear. Double-click the XQuartz.pkg icon to launch the

4.2. Installing Inkscape on OS X 10.7 - 10.10 39
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XQuartz installer. Follow the steps and instructions in installer to finish installing
XQuartz.

4. Restart, shut down, or log out of your Mac before proceeding to the next step.

4.2.2 Step 2: Install Inkscape

1. Using a web browser, go to the Inkscape 0.92.2 downloads page.

4.2. Installing Inkscape on OS X 10.7 - 10.10 40
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2. Click the box labelled Mac OS X 10.7 Installer (xquartz) to download the DMG
file, which contains the installer.

3. Once the download has finished, open your Downloads folder in the Finder. Once
again, you can open this folder by selecting Go → Downloads from the menu bar
in the Finder. Double-click the Inkscape DMG file to open it.

4. Click and drag the Inkscape icon to the Applications icon as instructed in this
window. This will install Inkscape on your Mac.

4.2. Installing Inkscape on OS X 10.7 - 10.10 41
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4.2.3 Step 3: Setting Up Inkscape

1. Open Inkscape by double-clicking its icon in the Applications folder. You can open
the Applications folder by selecting Go → Applications from the menu bar in the
Finder.

2. Click OK in this window, which appears the first time Inkscape is opened. Wait

4.2. Installing Inkscape on OS X 10.7 - 10.10 42
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for Inkscape to open. This might take a few minutes, since Inkscape is scanning
all the font files in your system. The next time you open Inkscape, it will not take
nearly as long to show up.

3. Once Inkscape does open, its interface will appear inside XQuartz. When Inkscape
is running, you will see the name “Inkscape” in the title bar of your window, but
the menu bar will show the name “XQuartz” .

4. With Inkscape open, select the XQuartz preferences by selecting XQuartz → Pref-
erences. . . from the menu bar.

4.2. Installing Inkscape on OS X 10.7 - 10.10 43
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5. Click the Input tab, and configure its settings as shown here.

6. Click the Pasteboard tab, and configure its settings as shown here.

4.2. Installing Inkscape on OS X 10.7 - 10.10 44
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7. Close Preferences. You are now ready to use Inkscape.

Note that when using Inkscape version 0.92 with XQuartz, its keyboard shortcuts use
the control key, rather than the usual command key.

4.3 Homebrew and MacPorts

In addition to the preceding “standard” methods of installing Inkscape, you can also
build Inkscape on your Mac using Homebrew or MacPorts. These methods are in-
tended for users who prefer these environments; most users should use the recom-
mended methods above. You will need to be familiar with the macOS terminal and you
may need to install Xcode and its command line developer tools in order to use these
methods. Depending on the type of Inkscape build, you may also need XQuartz.

4.3.1 Using Homebrew

1. Install Homebrew, using the instructions at the main Homebrew site.

2. See the Homebrew instructions for Inkscape for the specific Homebrew formula
to use.

4.3. Homebrew and MacPorts 45
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4.3.2 Using MacPorts

Install MacPorts. Read the guide on how to do so, since there are different methods
and requirements depending on your operating system version.

4.3. Homebrew and MacPorts 46
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FIVE

INSTALLING INKSCAPE ON GNU/LINUX

There are many different ways to get Inkscape for your GNU/Linux operating system.
Read on to find the best option for yourself.

5.1 Preinstalled

On many Linux distributions, Inkscape comes preinstalled—just select it from the
“Graphics” section of your application menu to start it up.

5.2 From your distro’s app store

Many Linux distributions come with an app store. In yours, type “Inkscape” into the
search field and select to install it. Note that the version you get from the store isn’t
necessarily the most recent one, and in some cases, also lacks some features.

5.3 The latest stable version directly from the Inkscape
project

For downloading and installing the latest version, visit the Download page on the
Inkscape website and select one of the various options for GNU/Linux.

Depending on the Inkscape version and your Linux distribution, these installation for-
mats may be available to you:

• AppImage

• Flatpak

• ppa (for Ubuntu and Ubuntu derivatives)

• Snap

• building Inkscape yourself from the source code

47
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CHAPTER

SIX

THE USER INTERFACE

Inkscape shows a window for each opened document. Each window contains various
toolbars and a white rectangle in the middle.

Hint: In this manual, we use the Wide view which puts the commands bar on the
right. You can get this view with the menu by selecting View → Wide Screen. Also, in
this manual, we use a light theme for better readability. If yours is dark, and you would
like to change the interface theme, select Edit → Preferences. Then select Interface →
Theming and deselect Use dark theme.

6.1 Interface Areas

• The application menu bar along the top provides general menu options. Some
are similar to other software programs (File → Save, Edit → Copy, etc.). There are
also Inkscape-specific items.

• The tool controls bar just below adjusts to the currently selected tool. It displays
adjustable options for the currently selected tool.

• Vertically on the left, the toolbox contains the main drawing tools, e.g. for cre-
ating and editing shapes, as well as to zoom in and out. Only one tool can be
selected at once.

• The large blank area is the canvas, where the image is edited.

• A white rectangle represents the visible page area.

• On the right side of the window, you can find the commands bar which gives
quick access to commonly used commands, which are also available via the drop-
down menus. If not all the commands are shown, there is a right-facing arrow
that gives access to the hidden choices.

• In the top right corner, a little arrow next to a magnet symbol lets you access the
snap controls. We suggest you deactivate snapping for now if they are active, by
pressing the magnet symbol, or by pressing %.
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Fig. 1: The main areas of the Inkscape user interface

• There are rulers at the top and on the left of the canvas, to help with grid and
guideline placement.

• Scrollbars are available to the right and bottom to move around on the canvas.

• The color palette is near the bottom of the window. Its most basic usage is to
change the fill color of an object. See also The Color Palette.

• At the very bottom, the status bar provides information such as the colors of
the selected object, layers, cursor coordinates, zoom level and page rotation. It
also contains a field where Inkscape can display helpful texts, such as the number
and type of selected objects, or tips about keyboard shortcuts and usage hints.
Whenever Inkscape doesn’t do what you think it should be doing, look here first.

• Dialogs for specific functionality will by default appear attached to the right of
the canvas, in the docking area.
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CHAPTER

SEVEN

MANAGING THEWORKSPACE

7.1 Document Properties Dialog

By default, Inkscape creates documents in a size that fits your operating system lan-
guage (that is, in the US, you get a different default document than in Germany, for
example). To change the page size, click File → Document Properties. . . (or click on the
next to last icon on the commands bar, which looks like , or use the Shift + Ctrl +
D keyboard shortcut). In the section Page Size on the Page tab, select or define the size
you wish.

The default measurement unit for page size can be changed in the Page Size section of
the same Page tab.

The large rectangular line that you see on the canvas, in a new blank document, is the
page border. If you compare the page border to the rulers, you can see that it represents
the page size. Note that the page border is never seen in exported or saved files.

Most of the time, everything that you want to show up in your finished drawing, must
be inside this border. Elements placed outside of the page border usually can’t be seen
when you share your drawing, and can be thought of as drafts, experiments or available
resources.

If you do not want to see the page border while you’re working, you can uncheck the
option Show page border in the Page tab to hide it. You can also configure the page
shadow and color of that shadow, in that section, if you like.

In Inkscape, the canvas appears white. Even though it does not use the traditional
checkerboard pattern to indicate transparency (by default), it really is transparent. If
you’d like to see a checkerboard pattern for transparency, please check the Checkerboard
background option in the section Background on the Page tab.

When a drawing is exported to a PNG format, areas on the page where there is no
object will be transparent. You can change this by putting an opaque object behind
your drawing (usually a rectangle, the same size as the page).

Another way to change this is by clicking on the color bar in the Background section of
the Page tab, and setting the A slider (“A” for Alpha) to 255, or all the way to the right.
You can also change the color, if you like. Note that this setting only affects how the
image looks in Inkscape or when you export to PNG.
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7.2 Options in ‘View’ Menu

Many people use Inkscape with no scrollbars and no snapping. Any unneeded bars can
be hidden in the menu View → Show/Hide. The canvas can be moved using the middle
mouse button.
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CHAPTER

EIGHT

WAYS OF DRAWING IN INKSCAPE

Inkscape offers several ways for creating vector images, which can, of course, be com-
bined:

• using the geometric shape tools

• using the path tools, much like a pencil on paper

• starting from a photo, a scanned image, or any raster graphic by using a tracing
engine

• using one of the many available features that let you create elements of a drawing
automatically

Often there are more than one ways to achieve the same result. Soon you will develop
your own habits and preferences for drawing with Inkscape. Only very rarely, there is
one way, and only one way, to accomplish something.

In this section, we’ll start out by exploring the easiest way to create a drawing in
Inkscape: the shape tools. We will also get to know some of the most commonly used
tools or features. If you have any prior experience with raster graphics (such as editing
photos), you will also begin to discover how creating and editing vector graphics is so
very different.
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CHAPTER

NINE

THE SHAPE TOOLS

Geometric shapes, despite their simple look, are useful for many drawing techniques
(and not only vector drawing). With path operations (Union, Difference, etc. . . ), you
can quickly get awesome results from some elementary shapes. You can even further
improve that with path tools. Both path operations and path tools are detailed in later
sections.

Let’s draw some geometric shapes. All the shape tools follow similar rules to let you
create and edit your shapes. But each tool has specific options: for example, a circle
can become a pie wedge, or a rectangle can have its corners rounded.

To create a geometric shape:

• enable the relevant tool in the toolbar by clicking on it;

• on the canvas, press the mouse button and hold while you drag the mouse;

• release the mouse button to display the shape.

Fig. 1: Click and drag to create a shape.
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Once the mouse is released and the shape is displayed, various handles will become
visible. Many of Inkscape’s tools use handles for one purpose or another. But it’s the
handles of the geometric shapes which are used for creating many fancy and exciting ef-
fects. The handles may be tiny circles, squares and/or diamonds. Sometimes, the same
handles can be available for different tools. We will learn more about each handle’s
function in the following chapters.

Fig. 2: Primitive shapes provide handles as squares, circles or diamonds.

Many features of Inkscape are accessible through keyboard shortcuts, and sometimes
even only through key shortcuts. While drawing your shape:

• press Ctrl while you drag the mouse, with the Rectangle and Ellipse tools, to
create squares and circles;

• press Shift while you drag to draw from the center, rather than from one corner.

Try drawing some shapes, with and without those keys to get an idea of how they can
be used.

Fig. 3: Sketching a cloud from ellipses.
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CHAPTER

TEN

THE SELECTOR TOOL

F1 or S

The Selector tool is a fundamental tool in the program, since almost everything must
be selected before it can be edited.

Working much like a hand, the Selector tool also moves, scales, skews and rotates
objects.

To move an object:

• position the mouse over an object;

• press the mouse button and hold, while dragging it to the desired position (hold
Ctrl to move the shape in horizontal or vertical direction only);

• release the mouse button.

Fig. 1: Drag to move the selection. Transformations (such as moving, scaling, rotating)
are easy thanks to the two-way arrows.

To scale (change the size of) an object:

• click on it to select it;

• position the mouse over a two-way arrow on a side or a corner;
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• press the mouse button and hold while dragging it to the desired size (hold Ctrl
if you want to preserve the proportions);

• release the mouse button.

To skew an object:

• select it, then click it again;

• position the mouse over a horizontal or vertical two-way arrow;

• press the mouse button and hold, while dragging it to the desired amount of skew
(also hold Ctrl for 15° steps)

• release the mouse button.

To rotate an object:

• select it, then click it again;

• grab a curved two-way arrow in any corner;

• drag it until the object reaches the desired angle (hold Ctrl for rotating in steps
of 15°).

Fig. 2: Click the selection a second time to access skew and rotating functions. The
cross in the middle of the box is the rotation center. It can be moved.

In some cases, you want to edit more than one object at once. So the Select tool can
select more than one object at once.

To select more than one object, there are mainly two ways:

• click the first object, then hold Shift while clicking each additional object once;

• or press the mouse button and drag out a rectangular selection box which encloses
all the objects.

You can combine the two methods: hold Shift to keep previously selected objects
selected, and drag out a selection box to add more objects to the selection. Doing this
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Fig. 3: Each selected object is framed with a dashed line (known as the bounding box),
while the two-way arrows for transformation are placed around the entire selection
(one or more than one object).

the other way around works, too: after selecting more than one object by dragging a
selection box, hold Shift while you individually click on more objects.

Also notice how the Shift key allows you to sort of toggle a selection: click to add to
the selection, click again to remove.

Hint: By default, selecting with a box will only select those objects that were com-
pletely enclosed by it. Press the fourth button on the tool controls bar to switch to
selecting everything that was touched by the box, whether completely or partially.

A blend of these two methods is selection by touch. If you press Alt at any time while
you are drawing a selection box, it will turn into a red path. Anything the path touches
will be selected.

Caution: Make sure you don’t have anything selected yet, if you want to use
selection by touch. Holding Alt will otherwise cause the objects to move along with
the mouse cursor, even if you didn’t click on any of them.
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Fig. 4: Selection by touch can be convenient, when the objects are too hard to select
with a box and so numerous that clicking on them one by one takes a lot of time.

10.1 Paste on top of selection

If you have copied an object to the clipboard, you can paste it directly on top of any
other object you select. This can be helpful, if the spot you want to insert the object
into is (partially) hidden below other objects in the drawing.

Fig. 5: The lower sandwich slice is selected and the mouse pointer is hovering right in
the center of it. Time to place the tomato slice.
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CHAPTER

ELEVEN

SQUARES AND RECTANGLES

F4 or R

To draw a rectangle:

1. Select the Rectangle tool from the toolbox on the left.

2. Click and drag the mouse diagonally, using the same motion as when dragging a
selection box.

The rectangle will appear immediately after you release the mouse button. To draw a
perfect square, hold down Ctrl while click-dragging with the mouse.

The square-shaped handles can be used to change the rectangle’s size. However, when
you only want to change either the height or the width of the rectangle, it’s hard to
control with the mouse alone. Here you can use Ctrl to restrict the size change to
either width or height of the rectangle.

Fig. 1: When you hold down Ctrl while dragging the square-shaped handles, it is easy
to limit the change in the rectangle’s size to a single direction.

The circle-shaped handles are for rounding the corners. Grab a circle handle and move
it just a tiny bit. You’ll see that all four corners will be rounded. Additionally, a second
circular handle has appeared now. Each handle changes the amount of rounding in one
direction. It is not possible to only round a single corner of the rectangle independant
from the others. They will all change together.
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Fig. 2: Moving the circle handles rounds the corners. Each circle handle changes the
radii in a different direction.

Fig. 3: The “Rx” and “Ry” values on the control bar, determine the radius of the imagi-
nary circle which the rounding is based upon.
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To restore the initial, sharp-cornered shape of a rectangle or square, click on the far
right icon in the tool control bar . This is very useful, when you’re still learning how
to master the usage of the circular handles!

When you need to draw a rectangle with accurate dimensions, you can use the tool
controls bar:

• the field labelled W is for the width;

• the field labelled H is for the height;

• the Rx and Ry fields define the rounding radius for the corners.

The dropdown behind each number entry field allows you to select the unit you need
for your rectangle.
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CHAPTER

TWELVE

CIRCLES, ELLIPSES AND ARCS

F5 or E

To draw a circle or ellipse, click and drag the mouse diagonally, using the same motion
as when dragging a selection box. The circle will appear immediately after you release
the mouse button. To draw a perfect circle, hold down the Ctrl key while you drag the
mouse. Holding Shift will start drawing from the center of the shape.

The Ellipse tool also allows you to draw arcs and circle segments (or “pie wedges”). To
draw an arc, grab the round handle and drag it, always keeping the mouse pointer on
the inside of the (imaginary) circle.

To draw a segment (“pie wedge”), drag the round handle, always keeping the mouse
pointer on the outside of the (imaginary) circle.

After the first drag, you’ll see a second round handle appear. You can set a specific
angle for these shapes on the control bar, using the Start and End fields. Note that the
three buttons to the right of those fields do not become activated until after you have
dragged the circle handles.

Fig. 1: Dragging the square handles converts a circle into an ellipse.

To quickly restore the circle/ellipse shape, click the far right icon in the tool controls
bar: .

To convert an ellipse into a perfect circle, click on one of the square handles while
pressing Ctrl. The top and left square handles change the size of the ellipse in vertical
and horizontal direction, respectively.
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Fig. 2: The round handles convert the shape into an arc or segment (“pie wedge”),
depending on the position of the mouse (inside or outside the imaginary circle) as you
drag the handle.

Fig. 3: The Start and End fields, on the tool controls bar indicate the angles between
which the pie or arc extends.

Fig. 4: If you prefer to have a closed shape instead of an arc, you can click on the
third icon on the tool controls bar to change the ellipse. That also works with

segments.
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To create a circle with a specific size, you can use the fields for the horizontal and
vertical radius Rx and Ry in the tool controls bar.
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CHAPTER

THIRTEEN

STARS AND POLYGONS

Shift + F9 or *

The Star/Polygon tool is perhaps the most exciting tool for beginners, and sets Inkscape
apart from other vector editing software! It offers numerous creative options which can
be edited on the canvas with ease.

As with the other geometric shape tools, drag the mouse on the canvas using a simi-
lar process as dragging a selection box. The default star, which has 5 points, will be
displayed with its 2 diamond-shaped handles, as soon as the mouse button is released.

If you need your star rotated in a specific angle, you can hold down Ctrl while drawing
it. This will make it ‘snap’ in 15° steps. If you drag the mouse downwards, the tip where
the mouse cursor is will be positioned exactly at 6 o’clock (or south).

The handle that is situated in the crease between two of the star’s tips changes the inner
diameter. The other handle changes the length of the star’s tips.

When you press Ctrl while dragging the star’s handles, you can change the tips’ length
and the inner radius without also rotating or twisting the star.

The field labelled Spoke Ratio on the tool controls bar will also work without any turning
or twisting the star. You can use the up and down arrows beside the field to change the
number there, too. Even holding the mouse cursor above the field and using the scroll
wheel will work.

If you prefer to draw a polygon, click the icon on the control bar, which is shown below.

With these few options, it’s already possible to create many different shapes, starting
from a single star. But there are even more options! To add more tips to a star or more
sides to a polygon, either enter the number of tips you want, in the field Corners in the
tool controls bar or click on the up/down arrows right beside it.

To round the tips of a star or the corners of a polygon, you can hold down Shift while
dragging any of the handles. The farther you drag them, the more rounding you will
get (drag the mouse horizontally for best results). Or as before, either use the arrows
next to the field Rounded in the tool controls bar, or change its value by entering a new
one.
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Fig. 1: The handle in the crease between two tips lets you make changes to the inner
diameter of the star. Without holding down Ctrl, it can be difficult to avoid twisting
the star. The other handle is used to change the length of the tips.

Fig. 2: In Polygon mode, the shape only has a single handle: This handle enlarges or
shrinks the shape. The star can be twisted, if you do not hold the Ctrl key.
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When you press Alt while dragging a handle, this will add some randomness to the
star or polygon. Or as before, use the number field with the arrows to change the value
for Randomized. A star’s tips will then all be of different length, and a polygon will look
distorted.

Fig. 3: Adding a slight rounding. Adding a little bit of randomness.

Fig. 4: The Star tool’s tool controls bar. The right-most icon resets to default values.
Very useful when you don’t know how to get back!

Fig. 5: Can you draw these stars?
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FOURTEEN

SPIRALS

F9 or I

This geometrical shape isn’t needed frequently, but sometimes, it proves to be very
useful.

To draw a spiral, click and drag with the mouse on the canvas. When the left mouse
button is released, the spiral will be finished. You will notice two diamond-shaped
handles on the spiral.

These handles change the length of the spiral. You can try this out right on the canvas:
Just grab one of the handles and drag it along the spiral’s turns to get the desired
number of turns and to make the spiral larger or smaller.

If you hold down Ctrl while dragging the handles, the spiral will get longer (or shorter)
in 15° steps.

When you combine pressing Alt with pulling the inner handle upwards or downwards,
it will change the divergence (tightness) / convergence (looseness) of the spiral, with-
out changing its overall size. Dragging upwards makes the turns move toward the
outside of the spiral. Dragging downwards will make them move closer to its center.

The easiest way to change the number of turns of a spiral quickly by a large amount is
to enter the desired number into the field labelled Turns in the tool controls bar. This
will not change the spiral’s diameter.

If you ever feel lost when working with the spiral tool, you can use the rightmost
icon in the tool controls bar to remove all changes and to reset the spiral to its initial
shape.
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Fig. 1: A basic spiral

Fig. 2: Changing a spiral using its handles.
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Fig. 3: Alt + dragging the inner handle downwards makes the spiral converge more.

Fig. 4: Alt + dragging the inner handle upwards lets the spiral more divergent.
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Fig. 5: A spiral with a large number of turns.

Fig. 6: A spiral with a smaller number of turns.
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FIFTEEN

3D-BOXES

Shift + F4 or X

The 3D-Box tool draws a (simulated) three-dimensional box. To understand how it
works, it helps to know a little bit about drawing in perspective. This tool is of interest
to people who want to draw architecture or interiors. It makes it really easy to cre-
ate furniture or rooms, because it automatically creates perspective, by making use of
vanishing points.

After click-and-dragging with the tool active, a box appears on the canvas. This is best
done somewhere near the center of the page area. Otherwise, the box can sometimes
end up quite deformed. By default, two vanishing points are placed in the vertical
middle of the page borders, one on the right, the other on the left.

When you look closely at the 3D-box that you have drawn, you will see the following:

• A small black crosshair, which designates the center of the box. When you click
and drag it with your mouse, the box will move along with it, apparently in 3D
space. Depending on its position in relation to the vanishing points, you will be
able to see the box’s bottom, or its top. If you move the box to the left or right, its
shape will change in accordance with the vanishing lines.

• Numerous (to be exact, 8) white, diamond-shaped handles allow you to extend
or shrink the box along the x, y or z axis by dragging them with the mouse.

• The white, square-shaped handles symbolize the vanishing points and can be
moved in the same fashion as the other handles.

Note that these specific changes can only be achieved when you use the 3D-box tool.
If you move the box with the Selection tool, both the box and the vanishing points will
move.

The tool controls for this tool allow you to set parameters for the 3 vanishing points for

the x, y and z axis. The buttons with the icon depicting two parallel lines will make
the vanishing lines parallel and have an immediate effect on the box on the canvas.
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Fig. 1: Dark blue: the top of the box. Medium blue: its left side. Light blue: its right
side.

Fig. 2: Moving the 3D-Box

75



, Release 1.0

Fig. 3: Moving the vanishing points.

Fig. 4: Adding a third vanishing point.
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CHAPTER

SIXTEEN

STACKING ORDER

If you have drawn objects that overlap each other, you can select an object and then
click “Raise” or “Lower” under the “Object” menu to change the stacking order.
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CHAPTER

SEVENTEEN

FREE DRAWING

The freehand drawing tools make it possible to draw directly onto the Inkscape canvas
using the mouse or a graphics tablet stylus. Depending on what and how you would
like to draw, you can select the best tool for the task. These tools are not based on
geometrical shapes. You can draw exactly the shape you need. With some practice, you
will get better and better in achieving exactly the result that you desire. And of course,
you can always modify the elements in your drawing with the path tools.

In this section, we’re going to first learn about how to use the Pencil, Pen and Callig-
raphy tools. This way, we will gently learn about the new concept of paths, which are
at the core of vector drawings. Later on, we will explore how to edit these paths.
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CHAPTER

EIGHTEEN

THE PENCIL TOOL

F6 or P

The behavior of the Pencil tool depends on the settings in its controls bar. To draw
with this tool, press the left mouse button and drag the mouse around the canvas. The
Pencil will leave a green trace that follows the location of the mouse cursor. When you
let go of the mouse button, the shape you created will get its stroke (and/or its fill, if
you have one set).

Two tiny, square handles appear at the start and end of the drawn path. When you start
drawing on one of these handles, this will continue the path, instead of creating a new
object. And if you stop drawing the same path in one of those squares, it will close the
path (meaning there are no openings).

Let’s have a look at the options of the Pencil tool. The Shape dropdown menu offers
different brushes that influence the shape of the path:

Triangle in and out
This makes the path look a little more elegant, thinning or thickening along its
length. Switch to the Node tool and drag on the pink diamond-shaped handle to
adjust the width interactively.

Ellipse
The beginning and end of the path will be thinner than its middle part. Switch
to the Node tool and drag on the round white handle to adjust the width interac-
tively.

From clipboard
You can make custom brushes by first drawing your brush shape, and then copying
it. This will add it to the clipboard automatically and can be used as a brush for
the pencil and pen tools.

Bend from clipboard
First you must copy a curve that already exists. The line that you draw will be
deformed like the path that you copied. And it will be adjustable, using the Node
tool.

Last applied
Use the same shape you used last time. Use this if you want to continue using a
custom shape, for drawing multiple lines with the same style. This way, you can
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go back to using the clipboard normally. It does no longer have to hold the shape
you want to draw.

None
The drawn path’s outline will be of the same width along the whole length of the
path.

You can set the amount of Smoothing for the path you want to draw. When you use a
mouse for drawing, making this value larger will make the line look less scrawly. When
you use a graphics tablet with pen, you can use a lower smoothing value, and it will
still look nice.

The button LPE based interactive simplify allows you to draw a path where you can
adjust the smoothing after you have finished drawing the path. Use the button LPE
simplify flatten to lock the result of the interactive smoothing. After it has been used,
the path’s smoothing can no longer be adjusted.

Hint: ‘LPE’ is the acronym for “Live Path Effect”, a set of functionalities specific to
Inkscape that can change paths non-destructively, to achieve spectacular results.

To reset your changes to smoothing to the default value, you can use the button where
the hover text says reset pencil parameters to default.

The pencil tool has three different modes. The results you get also depend a lot on the
level of smoothing:

Create regular Bézier path
The path that you get as a result is very close to the path that you drag with the
mouse cursor on the canvas. Remember to adjust the smoothing, to make your
line look more elegant.

Create Spiro path
Create stylish swirls and curls with only the mouse!

Create BSpline path
This mode reveals its use when you switch to the Node tool. It makes it really
easy to draw evenly smooth curves.

The Pencil tool (as well as the Pen tool) creates dots when you hold down Ctrl while
clicking on the canvas. When you hold down both Shift + Ctrl, the dots’ size will be
doubled. With Ctrl + Alt, random sized small dots will be created with every click,
and with Shift + Ctrl + Alt, each click will generate a random sized big dot.

Hint: Note that the dots are really circles.
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Dots created with the pencil tool. Top left: with Ctrl, top right: with Ctrl + Alt,
bottom left: with Ctrl + Shift, bottom right: with Ctrl + Alt + Shift.

A path drawn with Shape: Ellipse and no smoothing.

The path has been extended from the square handle at its end.|

The path has been extended from the square handle at its end.
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Shape: Ellipse with more smoothing.

Shape: Triangle out was used here.

This path uses Shape: From Clipboard

The path that was copied to the clipboard for drawing the above path.

Path drawn with Shape: Triangle In in Bézier mode, with a smoothing of 40
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Path drawn in B-Spline mode

Path with Shape: From Clipboard drawn in Spiro mode with a smoothing level of 40
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The same path as above, only wider. The width of a path that uses objects on the
clipboard (and those that use ‘Shape: Ellipse’, both use the ‘Pattern along Path’ Live
Path Effect) can be changed with the Node tool, using the white circular handle at the
beginning of the path.

The width of a path with a PowerStroke Live Path Effect (used by ‘Shape: Triangle In /
Out’) can be adjusted with the node tool by moving a pink, diamond-shaped node, to
achieve a non-constant path width.
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NINETEEN

THE PEN TOOL

Shift + F6 or B

When you’re first using this tool, it may appear complex, but very soon it will become
a good friend that you will enjoy to use for creating your illustrations.

This tool’s purpose is to draw paths. Multiple paths, drawn next to and on top of each
other, form a design. For a start:

1. Click with the left mouse button to create the first point (node) of the path.

2. Move the mouse and click again. Repeat this for as many nodes that you want to
draw. All your nodes will be connected by straight lines (segments).

3. To finish the path, right-click with the mouse.

It’s also possible to draw curves with this tool. Every node you create has two handles.
These handles define the shape of the curve. To draw a curve directly, you can:

1. Click with the left mouse button to position the first node.

2. Keep the mouse button pressed and move the mouse slightly.

3. You are currently moving one handle of the node.

4. Left-click and drag to continue the path, or right-click to finish it.

The first method is predestined for creating precise drawings. First, you position the
nodes, later, you can use the node tool to modify the path.

You’ll be able to choose from several modes: Bézier, Spiro, BSpline, straight lines,
paraxial (= only strictly parallel and perpendicular). Then, there is the Shape option
that you have already learnt about in the chapter about the Pencil tool.

With some experience, you will learn how to place your nodes strategically. When a
path contains too many nodes, this will make working with it more difficult. On the
other hand, when there aren’t enough of them, you will find that you have a lack of
control when you are tweaking the path.

The path has been modified by making the straight segments curved with the help of
the node tool.

Some final adjustments have been made, to achieve a nice result. The image now
resembles an open book.
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Fig. 1: Every left-click adds a node. A long left-click drags out a node’s handle and
makes the segment curvy.

Fig. 2: Creating the rough shape with the Pen tool, without thinking too much about
any curves. The nodes are represented as grey diamonds.

Fig. 3: The nodes have been aligned vertically and horizontally using the Align-and-
Distribute dialog.
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TWENTY

THE CALLIGRAPHY TOOL

Ctrl + F6 or C

What a goose quill was in antiquity, is Inkscape’s calligraphy tool in the digital world.
Ideally, it should be used with a graphics tablet and stylus, with one hand on the graph-
ics tablet and the other one on the keyboard, which moves the canvas, so one can write
without interruption.

Fig. 1: A varied set of options exists for simulating different brushes, in case the default
brushes that come with Inkscape do not suffice.

Dip Pen
Emulates a bevelled pen tip.

Marker
Emulates a round and regular tip.

Brush
Emulates a soft, thinning ellipse.

Wiggly
Emulates a very jumpy round brush.

Splotchy
Emulates a quill.

Tracing
This allows you to emulate an engraving, by drawing more or less regular lines
over a drawing that serves as a model.

The button to the right, Add or edit calligraphic profile, allows you to save and load the
settings made in the following options, under a brush name of your choice.

Every brush is a result of the following parameters:
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Fig. 2: The ends of a line drawn with the Dip Pen setting are cusped.
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Fig. 3: With the Marker setting, the paths look smooth and their ends are rounded.
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Fig. 4: The setting Brush creates slightly rounded and uneven strokes.
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Fig. 5: The Wiggly setting allows you to draw very organic shapes.
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Fig. 6: When set to Splotchy, the result looks a bit like calligraphy.

Fig. 7: With the calligraphy tool setting Tracing, drawings that look like an old engrav-
ing can be created. The image below serves as a model.
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Width
Here you can set the width of your brush.

Pressure sensitivity
This option is only useful when a graphics tablet is used for drawing.

Trace lightness
Needs to be active when you want to use the Engraving feature.

Thinning
Determines the width of the brush stroke at the start and end of the line.

Angle
Determines the quill’s angle.

Fixation
Determines how much the angle will change when the draw direction changes.

Caps
Determines the shape of the brush stroke’s ends.

Tremor
Adds a little randomness to the brush stroke.

Wiggle
Adds the unexpected.

Mass
Simulates the weight of the tool used, which has an impact on the stroke’s shape.

Like the Pencil tool and the Pen tool, the Calligraphy tool can create dots. Simply click
in place without moving the mouse to create a small dot or hold Shift and click to
create a large dot.
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BOOLEAN OPERATIONS

The Boolean Operations work on paths, or they try to convert the selected objects to
paths before they compute the result. All these operations need at least 2 convertible
objects or paths, which will be combined following specific rules.

Union
Keeps the common outline of all selected paths.

Difference
Subtracts one path from another one.

Intersection
Only keeps those parts that are covered by all selected paths.

Exclusion
Keeps those parts which are covered by an odd number of paths (if you have two
objects, this is where the objects do not overlap).

Division
The path below is cut into pieces by the path above.

Cut Path
Creates as many paths as there are path intersections between the two paths.

Combine
Keeps all parts, and combines them into a single object.

Break Apart
If a path consists of a number of independent parts (subpaths), this will create
that number of separate objects.

To use these operations, select the two (or more) objects, and then select the option of
your choice in the Path menu. The result will immediately appear on the canvas - if it
doesn’t, read the error message that will appear in the status bar, at the bottom of the
Inkscape window, to find out about the reason for the failure.

Hint: The stacking order of the object matters, so check that the bottom object is the
one you want to apply the operation to. To know how each operation will apply, look
at the icons: the circle is always on top of the square.
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Fig. 1: Unioning a triangle and a square gives a house.

Fig. 2: Difference between a rectangle and a house creates an opening for the door.

Fig. 3: Two overlapping ellipses. On the left: Intersection between the two ellipses. On
the right: Exclusion between the two ellipses.
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Fig. 4: Someone has drawn a path with the pencil tool on the orange ellipse on the left.
On the right: Division.

Fig. 5: On the left: Move apart and combine (to form a single path composed of two
subpaths). On the right: Break Apart separates all subpaths into independent objects.
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EDITING PATHSWITH THE NODE TOOL

F2 or N

The second-most used tool in Inkscape is the Node tool. It will be your friend when
you need to edit a path.

What you need to know about paths

Every path consists of nodes that are connected to each other, like pearls on a string.
The ends of this string can be connected like in a chain (closed path), or there can be
two end nodes, that are only connected to one other node (open path).

Fig. 1: On the left side, there is an open path. On the right side, it has been closed by
connecting the two end nodes.

Each node can only be connected to one or two other nodes. It’s impossible to attach a
third line to a node. When you need to draw a branching, you must create a separate
path for one of the branches.

In Inkscape, a node’s position is marked by a square, circle or diamond handle on the
line that represents the path.

A path’s shape can be changed radically by moving the nodes it consists of:

1. Activate the Node tool.

2. Click on the path to select it.

3. Click and drag the node you wish to reposition.
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Fig. 2: This node has an incoming and an outgoing path segment connected to it.

Fig. 3: You can move a node by grabbing it with the mouse.

For more gradual changes, paths can be edited by their nodes’ handles. Each node can
have up to two circular handles that are connected to it by thin lines. These handles can
be moved around with the mouse, too. The handles control the shape of the adjacent
path segment.

1. Activate the Node tool.

2. Click on the path to select it.

3. Click on the node you wish to edit.

4. Click and drag on the node’s handle(s).

Fig. 4: You can modify path segments by moving the node’s handles.

You can also manipulate the lines between the nodes (the path segments) directly, using
the Node tool. Click and drag on the path segment that connects two nodes, to change
its curvature, without having to use the handles for this.
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Fig. 5: Dragging directly on the path gives quick results.
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NODE TOOL OPTIONS

F2 or N

The Node tool offers a number of options we haven’t seen yet. In this chapter we will
go through them, by looking at the different icons in its tool controls bar:

Insert new node
A double-click on a path segment lets you add new nodes easily directly on the
canvas. If you need to add more nodes, or want to insert a node right in the
middle between two other nodes, you can click on the path segment or select
multiple nodes, then use this button. More nodes allow you to more precisely
determine the shape of a path.

Delete selected nodes
Select the node(s) and then either use the Del key, or use this button. You should
aim for having as few nodes as possible, so you can make changes to the objects
in your drawing more quickly.

Join (merge) nodes
Select at least two nodes. When you click on the button, the nodes will be merged
into a single node. Inkscape will try to preserve the path’s shape as well as possi-
ble.

Break path
This will split one node into two nodes. These two new nodes are not connected
by a path segment. The new nodes only have a single handle, as they are end
nodes, and they are placed directly on top of each other. This can sometimes be
difficult to handle. Only use this feature when you really need it!

Join end nodes with a new segment
This is ideal for manually joining separate path pieces. If you select all nodes in
a path that has many interruptions, this will always join the two nodes that are
closest to each other.

Delete segment between two non-end nodes
Breaks a path in two, leaving a gap.

The next couple of icons can be used to convert one thing into a different one:

Convert different node types into each other
see chapter ‘About Node Types’
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Convert objects to paths
We learn about this in the chapter about how to edit the nodes on a geometrical
shape

Convert stroke to path
Convert strokes of objects into separate objects

Then, there are number fields for changing the x and y coordinate of the selected node,
and a drop-down menu that allows you to change the unit for the coordinates.

These buttons determine if certain path properties will be editable and visible on the
canvas:

Fig. 1: An object where a node has been added by double-clicking on the path.

Fig. 2: A stroke was added, and another node. This node was broken into two. This
one looks a lot smaller. Make sure you really want this before clicking the button!

Fig. 3: The segment between two nodes has been deleted.
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Fig. 4: Example of editing a path by . . .

Fig. 5: . . . moving a node, then . . .
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Fig. 6: . . . changing a node’s type and modifying the handles.
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ABOUT NODE TYPES

F2 or N

You have probably noticed that the node handles don’t all look the same. Inkscape has
a number of different node types, that each behave in a specific way:

Cusp nodes
Used for creating corners, or for being able to freely modify the curvature of the
path. The handles can be moved independantly. A cusp node is diamond-shaped.

Smooth nodes
Used for drawing beautiful, flowing curves. Both handles and the node are
aligned on a straight line. Smooth nodes look like ordinary squares.

Symmetric nodes
Used for drawing soft curves. The handles are not only on the same line, but also
both at the same distance from the node. Symmetric nodes look like squares, too,
but their handles always move together.

Auto-smooth nodes
Used for drawing nice curves, without worrying about handles or segment shapes.
The handles sit on a straight line, and their distance from the node adapts auto-
matically when you move the node, so a smooth curve is drawn. A smooth node
has a circular shape.

To change a node’s type:

1. Switch to the Node tool by clicking on its icon.

2. Click on the path you want to modify.

3. Click on the node that you would like to convert to a different node type, or select
multiple nodes.

4. Then click on the corresponding icon in the tool controls bar to set the node type.

Beginners often prefer to use cusp nodes, because they are easy to use, although very
often, smooth nodes would be the better choice.
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Fig. 1: Cusp nodes make sharp corners.

Fig. 2: A smooth node creates a rounded curve.
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Fig. 3: A symmetric node creates a symmetrical curve.

Fig. 4: Auto-smooth nodes adapt automatically when you move them.
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EDITING NODES ON A GEOMETRICAL SHAPE

There are multiple ways to modify an object in your drawing. If the object is a rectangle,
an ellipse, a star or a spiral, i.e. a geometrical shape drawn with one of the shape tools,
then this object is a shape, and not a path.

Shapes can only be modified by dragging their specific handles. In contrast to shapes,
you will edit a path with tools that are meant for modifying paths.

However, shapes can be converted into paths, so the path tools can then be used with
them.

To convert a shape into a path:

1. Select the shape with the Selector tool.

2. In the menu, select Path → Object to path.

Warning: A shape can always be converted to a path, but a path can never be
converted back into an object!
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THE TWEAK TOOL

Shift + F2 or W

The Tweak tool is the ideal tool for illustrators who first draw their designs on paper,
then scan and vectorize their work. With it, you can modify paths on the canvas, using
numerous options, without ever switching tools.

As the tool only works on selected objects, first select the path that you would like to
modify. Then switch to the Tweak tool and click on the area that you wish to edit, or
click and drag the tool over the canvas.

First, let’s have a look at its general options:

Width
Determines the size of the tool. If you only want to edit a small region on the
canvas, make the circle smaller, else, make it bigger.

Force
Determines how strong the effect of the tool will be.

Pressure sensivity
Activate this button to use the pressure sensitivity of your graphics tablet to dy-
namically change the force of the applied effect. However, the tool can be used
well without a graphics tablet.

Now let’s look at the heart of the tool, its different modes:

Move objects
The first three icons move the selected objects in various directions. Read the hint
in the status bar to learn about additional key presses that change how the tool
works.

Shrink/Grow objects
Reduces the size of the paths, or, when you hold down Shift, enlarges the paths.

Rotate
Rotates the paths.

Duplicate
Creates duplicates of the selected paths. These will be placed directly above the
originals, so remember to move them, if you want to see the effect.
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Push path parts
Deforms the paths by pushing the nodes like a snow shovel.

Shrink / grow path parts
The borders of a part of a path will be moved closer to each other, with Shift,
they will be moved farther away from each other.

Roughen path parts
Roughens the contours of a path.

Paint color and Jitter colors
These modes modify the color of the paths.

Blur objects
Adds blur to the paths.

This drawing will serve as an example. The chameleon was drawn with a pencil, and
afterwards it has been vectorized with Inkscape.
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The tail needs to be edited, so it will gradually become thinner. Here, the effect has
been exaggerated for demonstration purposes.

Some roughening has been added to the tongue, to emphasize the beast’s dangerous
side.

110



CHAPTER

TWENTYSEVEN

COLORS

Colors of objects can be added and changed at any time when you’re working with
Inkscape.

For a vector object, a separate style can be defined for its outline (or stroke) and its
main color (or fill). This can be a plain color (e.g. dark red), a pattern (e.g. stripes or
flowers), or a gradient (e.g. a smooth transition from green to blue).

Inkscape comes with a couple of patterns, but also makes it easy to create your own cus-
tom patterns. Adding a plain color—that is, a uniform color—can easily be achieved
by using one of the ready-made palettes. Gradients are created directly on the canvas
with a dedicated tool.

In this section, we are going to learn how to apply a plain color in various ways, how
to create custom gradients and how to use stock patterns and create our own custom
patterns. We will also learn how to modify the stroke style (e.g. make it dashed) and
how to use markers.
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THE COLOR PALETTE

At the bottom of the Inkscape window, you can find the color palette.

The quickest way to apply a color to an object is to:

1. Select the object with the Selector tool.

2. Left-click on the color of your choice in the palette.

3. The color will be immediately applied to your object.

You can also click-and-drag the color on your object to use that color for your object.

Each vector object can have a stroke color and a fill color. To apply a color to the stroke:

1. Select the object with the Selector tool.

2. Hold down Shift and left-click on the color field of your choice.

3. The color will immediately be applied to the object’s stroke.

If you do not like the colors offered by the current palette, you can use one of the other
palettes Inkscape supplies. To switch the palette:

1. Click on the tiny triangle to the right of the palette, near the margin of the
Inkscape window.

2. Click on the name of another palette.

You will also notice that there are options for changing the palette’s appearance at
the top of the palette menu, which allow you to make the palette more or less tightly
arranged.

Tip: Custom palettes

It’s also possible to create your own color palette. To do so, create an Inkscape file
which contains only the colors that you want to be included in your new palette, for
example, by drawing a series of rectangles and giving each one a different fill.

Next, check where Inkscape looks for custom palette files. For this, go to Edit → Prefer-
ences → System, and make a note of the path indicated under User palettes.

Now, go to File → Save as and select the file extension GIMP palette (*.gpl). Save this
file in the location you have looked up in the previous step. If the subfolder palettes
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does not exist yet, you need to create it.

Lastly, you can make a backup of this file for later adjustments, by saving it normally,
as Inkscape SVG, to a folder of your choice.

If you like, you can now adjust the name of your new palette and the order and names
of its colors, by editing the file with a text editor:

The customizable name of the palette is in the second line of the file, after the keyword
Name:. This line is followed by a list of your colors, each in a separate line, containing 3
columns with their RGB values, and the customizable color names in the fourth column.
By default, colors are ordered by their RGB values, but you can swap the color lines
around to customize their order.

Restart Inkscape to see the new palette in the list.

An object with a light blue fill and a dark blue stroke

113



, Release 1.0

The colorful palette is located at the bottom of the window. The palette options menu
is unfolded.

114



, Release 1.0

The fill color can be dragged from the palette onto the object.
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THE FILL AND STROKE DIALOG

Shift + Ctrl + F Object → Fill and Stroke

Apart from the options listed under the title of this chapter, this dialog can also be
opened by double-clicking on the fields for fill and stroke at the bottom left of the
Inkscape window.

The dialog has 3 tabs: one for the Fill, one for the Stroke paint and one for the Stroke
style. The first row of buttons in the tabs for fill and stroke paint are for setting the type
of fill or stroke paint that you want to use:

• The cross needs to be active when you do not want to have any fill or stroke
paint respectively.

• The first square must be activated if you want to apply a flat, uniform color.

• The second square with the gradually changing color must be set when you
want to use a linear gradient.

• The third square with the brighter color in the middle is for setting a radial
gradient.

• The next square with its four quarters is needed for using a mesh gradient.

• The patterned square when active will allow you to apply a pattern.

• The white square is useful when you want to reuse the fill for other objects
in the same document. It acts like a library.

• The question mark does not set any specific color. The object inherits the color
of its parent.

Below, you can customize your color - we will return to that in the next chapter. At the
bottom of all 3 tabs, there are two fields that set values for the whole object:

• Blur: when you click, or click-and-drag in this field, you can apply a blur to the
whole selected object. Be warned: in most cases, values greater than 2% are
pretty useless.

• Opacity: when you click, or click-and-drag in this field, this will change the global
opacity of the selected object - changing the opacity of fill and stroke equally.
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Fig. 1: The first tab of the Fill and Stroke dialog, when an object with a plain light blue
fill is selected.
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Fig. 2: In the second tab of the Fill and Stroke dialog, the stroke is dark blue. . .
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Fig. 3: . . . and 10 mm wide in the third tab.

119



CHAPTER

THIRTY

CUSTOM COLORS

Shift + Ctrl + F Object → Fill and Stroke

When the palette does not contain the color you would like to use, you can select a
color in the Fill and Stroke dialog. We will now take a closer look at that dialog.

At the top of the dialog, there are 3 different tabs: for the Fill, the Stroke paint, and the
Stroke style.

In both the Fill and the Stroke paint tabs, you will find 6 different color selection
modes: RGB (Red, Green, Blue), HSL (Hue, Saturation, Lightness), HSV (Hue, Satu-
ration, Value), CMYK (Cyan, Magenta, Yellow, Key/Black), Wheel (Color wheel) and
CMS (Color Management System).

This book will not go into the details of the differences between these modes, but there
are different use cases for them. Many people find the HSL color selector the easiest
to use. The CMS color selector is reserved for advanced uses, and only makes sense in
combination with the open source desktop publishing software Scribus .

For choosing a color for your first drawings, you can select any of the first five options.

To select your color, click or click-and-drag with the mouse in the different sliders (or
the wheel). Always remember to first select your object! The result will immediately
be displayed on the canvas. When you’re happy with it, don’t touch anything in the
dialog!

Every color chooser also has a field labelled A at the bottom. ‘A’ stands for ‘Alpha’,
which is the opacity value of the selected color. The higher the value for alpha, the
more opaque your color will be.

In case you were wondering about that little field labelled RGBA in the bottom right
corner of the dialog: it is the name of the color in hexadecimal code, as it is used in
a web page’s CSS. The last two letters appended to the code determine the opacity or
‘alpha value’ (just like the slider labeled A).
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Fig. 1: A light blue color in RGB color space, which is mostly used in monitors.
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Fig. 2: The HSL color space is modelled after the way humans perceive colors.
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Fig. 3: As with HSL, the HSV model is used for human perception of colors. It shows
how colors are perceived under light.
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Fig. 4: The same light blue color in CMYK color space, which is commonly used in
printers.
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Fig. 5: The color wheel offers an alternative way to select HSV values.
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Fig. 6: Our mountains are light blue at the beginning.

Fig. 7: But we prefer them green.
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Fig. 8: And we choose a green stroke.

Fig. 9: If we lower the alpha value for the fill, we can see that the sun is about to rise
behind our green mountains. Note that the stroke is still completely opaque.
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COPYING A COLOR

There are several ways to apply the same style to multiple objects:

• Selecting multiple objects: select all the objects whose color you want to change
(hold Shift and click, or drag a selection box around them), then open the Fill and
Stroke dialog, select a color. It will be applied to all selected objects automatically.

• Use the Dropper tool: select an object, then activate the Dropper tool by clicking

on its icon , then click on the canvas, on an area where it has the color that
you want to apply. The selected object’s color will change accordingly.

• Copy the complete style of an object to apply it to another object: select the
object, copy it to the clipboard with Ctrl + C, then select the second object and
paste only the style with Shift + Ctrl + V. This not only copies the fill and stroke
color, but also the stroke width and style, a text’s font style and any patterns or
gradients.
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CREATING GRADIENTS

Ctrl + F1 or G

Inkscape allows you to comfortably create and modify gradients on-canvas. However,
it is useful to always have the Fill and Stroke dialog within reach, so you can modify
the colors easily.

The Gradient Tool can be activated in the tool bar. To apply a gradient to an object, you
need to first select an object. Then, click-and-drag over the object with the Gradient
tool.

There will now appear two new handles on the object, one square, one circular, which
are connected by a blue line. The square symbolizes the beginning of the gradient, and
the circle its end.

By default, the tool creates linear gradients with two stops (i.e. 2 handles with one
color each). The color of the start stop is opaque, the color of the end stop is entirely
transparent. This way, your object will look as if it is fading out.

To change a gradient’s direction and position, just move the square or the circular
handle with the mouse.

To edit a gradient’s colors:

1. select one handle of the gradient (circular or square) with the Gradient tool

2. in the Fill and Stroke dialog, select the color you want, or click on a color in the
palette to assign it to the selected gradient stop.

To create a gradient that has more than 2 colors, you can double-click with the Gradient
tool on the blue line that spans between the handles. This will create a new, diamond-
shaped handle. You can now change its color. The result will immediately show on the
canvas. When you move the diamond-shaped handle along the line with the mouse,
the colors of the gradient will move, too.

You can transform a linear gradient into a radial one by using the top row button in
the Fill and Stroke dialog. You can also replace the old gradient by creating a new one
with the Gradient tool. For this, the button for radial gradients in the tool controls bar
must be selected.

When an object has a radial gradient applied to it, the gradient is symbolized not by a
straight line, but by an angle, that has a square handle in the middle, and two circular
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handles at the end of its arms. The length of the arms represents the diameter of the
radial gradient.

There can be separate gradients applied to an object’s fill and to its stroke.

Fig. 1: A rectangle that has a gradient going from yellow to transparent. At the top,
the tool controls bar indicates that the object has a linear gradient with two stops, one
yellow, the other transparent. Each stop can be modified with the Fill and Stroke dialog,
after the corresponding stop has been selected on the canvas.

Fig. 2: A linear gradient with 5 stops.
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Fig. 3: The position of each stop (color) can be changed directly on the canvas.

Fig. 4: A linear gradient can be transformed into a radial gradient and the other way
around.

Fig. 5: A radial gradient can be moved as a whole by dragging on the square handle.
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CREATING AMESH GRADIENT

This tool is especially useful for those who want to create photorealistic designs, but it
also has its uses for everyone who wants to create complex gradients in a single object.

To apply a mesh gradient to an object, select the object.

Now you have two options:

Option 1:
Activate the Mesh Gradient tool in the tool bar. Use it to click and drag on the
object.

Option 2:

Open the Fill and Stroke dialog. There, select the Mesh Gradient mode .

Now, the mesh gradient will be displayed directly on the object. It has some different
kinds of nodes:

• grey diamond-shaped nodes for assigning colors

• white circular (or arrow-shaped) handles for shaping the mesh

Note: You will only be able to see and modify these nodes when you use the Mesh
Gradient tool.

In the tool’s tool controls bar, note the fields labelled Rows and Columns. More rows or
columns add more nodes that can each have a separate color. This way, an object can
be painted in a multitude of colors. New meshes will have the set number of rows or
columns.

To add more rows or columns to an existing gradient, double-click on the vertical or
horizontal mesh lines.

To apply a color:

1. select a grey node

2. select the color of your choice.
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Tip: You can use the dropper icon at the bottom of the Fill and Stroke dialog to
more quickly apply colors that you already use in your drawing.

Just like the normal gradients, mesh gradients can be shared between objects, when
both objects use a gradient with the same name (e.g. mygradient1234). Select the
gradient in the Mesh Fill list in the Fill and Stroke dialog to reuse it on a different
object.

Fig. 1: This cloud consists of 10 different colors. Each color has been applied to one of
the grey diamond-shaped nodes. The shape of the mesh has been modified to better fit
the shape of the cloud.
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Fig. 2: A landscape with mesh gradients
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Fig. 3: The same landscape without mesh gradients
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USING PATTERNS

Inkscape comes with a couple of preset patterns. To apply them to an object, you need
to:

1. select the object on the canvas

2. open the Fill and Stroke dialog, and in the Fill (or Stroke paint) tab, click on the

icon for patterns

3. You will then see a dropdown menu with many pattern names. Select any pattern
from the list to apply it immediately to the object.
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Fig. 1: Object with stock pattern ‘Polka dots, medium’ and a view of the list of available
patterns
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MODIFYING PATTERNS

A pattern can easily be rotated, enlarged or shrunk. When the node tool is active, an
interesting trio will appear in the top left corner:

• a cross, which you can use to move the pattern

• a white, circular handle that allows you to rotate the pattern.

• a white, square-shaped handle, which enlarges and shrinks the pattern.

When you grab these handles with the mouse and drag them, they will affect the pat-
tern, and the result will immediately be visible.

Fig. 1: Standard pattern with vertical stripes.
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Fig. 2: The pattern has been rotated, using the circular handle.
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Fig. 3: The pattern has been enlarged, by dragging the square handle.
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CREATING CUSTOM PATTERNS

You can make your own patterns in Inkscape. A pattern can consist of a texture (i.e. a
raster image like *.jpg or *.png that you imported), a group, a path, shape objects, . . .

Select the object that you would like use as a pattern, and then tell the software to turn
it into a pattern via Object → Pattern → Objects to Pattern. Your pattern will appear on
the canvas, applied to a rectangle. It will now also be available in the Fill and Stroke
dialog, next to the stock patterns that come with Inkscape.

The Pattern to Objects option in the same menu allows you to do the opposite operation.
This is useful when you want to modify a pattern, or want to extract an object from it.

Your first patterns may look a little surprising to you. When you start designing beauti-
ful seamless patterns, you are engaging in the art of illustration.

Fig. 1: This octopus image is using a custom fish pattern.
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STROKES

An object’s stroke is handled independently from its fill. Two of the tabs of the Fill and
Stroke dialog are dedicated to styling strokes.

You can assign a paint to a stroke. This works in the same way as assigning a paint to
the fill does (but in the Stroke tab). The stroke paint can not only be a flat color, but
also a radial or linear gradient, a pattern or even a gradient mesh.

In the Stroke Style tab, you can set the width of the stroke, the shape of its joins and
end caps or select a dash pattern (simple stroke, various dash lengths,. . . ).

Check the zoom level (in %) in the bottom right corner of the window to be sure that
you’re applying a suitable width. The more you zoom in, the wider the stroke will
appear.

The options for Join and Cap slightly modify the shape of the stroke. The default values
are fully sufficient in most cases.

The Dashes dropdown list gives access to a large selection of different dash styles, that
give you regular dash patterns along the stroke. The number field to the right allows
you to shift the dash pattern to the desired location.

It is impossible to apply blur only to an object’s stroke. The options for Blur and Opacity
always apply to the object as a whole.

Fig. 1: Black flat color on stroke
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Fig. 2: Linear gradient with 3 stops. The dotted lines indicate the spread of the color
for each stop.

Fig. 3: Radial gradient with 5 stops on the stroke. The dotted ellipses indicate the
spread of the color for each stop.

Fig. 4: The 3 different types of line joins.
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MARKERS

Markers are little symbols that can be added to the start of a path, to its end, and to
the line in between those. They will be placed on the path’s stroke. This is very useful
when you want to create arrows and diagrams quickly!

Markers will be located exactly on the nodes of the path. The start marker will appear
on the first node of the path, the middle markers on each node along the path, and the
end marker on the last node of the path.

Inkscape offers lots of different markers for you to choose from. You can look at them
in the Stroke Style tab of the Fill and Stroke dialog, in the row labelled Markers. The
left-most drop-down menu is for the start marker, the one in the middle for the middle
markers, and the right-most one for the end markers.

Markers automatically take on the fill and stroke of the path they are attached to. In
older Inkscape versions, the extension Extensions → Modify Path → Color Markers will
do this for you.

If your arrows point into the wrong direction, you can change the direction of the path
(Path → Reverse).

Fig. 1: List of available markers
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THIRTYNINE

ORDERING MARKERS, STROKE AND FILL

An object’s path determines its shape. The stroke is centered on the path, one half of
it on the inside of the path, overlapping with the fill, the other half is on the outside.
Markers, too, are centered on the path.

In the Order section of the Fill and Stroke dialog, you can select the order in which these
different parts of an object will be drawn. This way, you can place markers (and / or
strokes) above or below the fill.

Fig. 1: The available marker orders’ icons

Fig. 2: [top] markers > stroke > fill [bottom]
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Fig. 3: [top] markers > fill > stroke [bottom]

Fig. 4: [top] stroke > marker > fill [bottom]
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Fig. 5: [top] stroke > fill > markers [bottom]

Fig. 6: [top] fill > markers > stroke [bottom]
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Fig. 7: [top] stroke > fill > marker [bottom]
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CREATING CUSTOMMARKERS

Just as you can create custom patterns, you can also create your own custom markers.
In order to do so, draw the marker you’re envisioning, then make it available for use by
doing Object → Object to Marker.

Your marker is now available at the top of the list of markers in the drop-down menu
(Fill and Stroke dialog, third tab).

Fig. 1: We have drawn our markers and our path. For the ends, in this case we want to
have two mirrored markers.
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Fig. 2: Now we convert the object to a marker. It will be gone from the drawing after
this operation.

Fig. 3: In the Fill and Stroke dialog, we have selected the new markers for the start,
end and middle of our path. They are placed on the nodes of the path. The size of
the markers depends on the size of the objects that were converted to a marker. It also
changes with the stroke width of the path.
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FORTYONE

TEXT IN INKSCAPE

There is one menu which is dedicated to everything related to Text, which makes it
easier to add text to adverts or logos. The text can be added as a normal text, or in a
frame for a auto-wrapped text.

At any time, the font, font size and color of the text can be changed. You can also make
interesting modifications such as making a text follow the course of a path or flowing
it into an irregularly-shaped frame.

Once a text has been converted to a path, the text can be deformed just like any other
path, to achieve a specific visual design or typography.

Typographers will appreciate the option to create SVG fonts with Inkscape. The ded-
icated dialog allows you to directly see the result, in a preview that updates as you
type!
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FORTYTWO

WRITING TEXT

F8 or T

Once the Text tool is active, you will have two options at your hands about how to
create a text.

When you want to add a text that consists only of a single word or a short expression,
the easiest way to add it is to:

1. Left-click on the canvas to place the cursor at the desired position.

2. Type the text directly afterwards. The text will all be put into a single line, unless
you hit Enter to continue in the next line.

When you want to put your (longer) text into a specific area that you have reserved for
it:

1. Click-and-drag on the canvas. This will create a frame for a flowed text with a
blue border, in which the text can be inserted.

2. Type on the keyboard. The text will appear in its frame and will not leave the
frame area. When it reaches the border of the frame, it will automatically flow
into the next line. The border of the text frame will turn red when the text doesn’t
completely fit into it.

3. You can change the dimensions of the text box by dragging on the white handle
in the bottom right corner.

Note: The text will not stretch or grow to fill the allotted space at all costs. It is up to
you to adapt the size of the area or the font to your needs.

Fig. 1: A left-click on the canvas with the text tool positions the cursor.
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Fig. 2: This mode does not automatically break lines in the text.

Fig. 3: You need to create a text frame with the text tool first, if you want to use a
flowed text with automatic line breaks.

Fig. 4: At any time, you can modify the text frame using its handle.
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FORTYTHREE

STYLING TEXT

Shift + Ctrl + T, Text → Text and Font

The Text and Font dialog is ideal for modifying a text’s style. Most of the options that
are available in that dialog can also be found in the horizontal tool controls bar at the
top of the canvas:

• a field with a list of the fonts that are installed on your computer

• the font style (bold, italic, condensed, regular etc.)

• the font size

• the line-height or spacing between lines

• the icons for the text alignment (left, right, centered)

• two icons for quickly adding superscript or subscript

• a field for setting the spacing between letters and one for the spacing between
words

• two fields for horizontally and vertically shifting single or selected letters (kern-
ing) and one for rotating them

• icons for changing the text’s direction and orientation.

In the dialog, you will see a small preview of the result of your settings, and a tab
labelled Text that can hold the whole text without displaying any styling. Once you
have all parameters tweaked to your liking, you can click on Apply to make the result
show up on the canvas.

Inkscape does not come with any fonts. It will allow you to select from those that you
have installed on your system. When you install a new font while you are working on
a drawing, you need to close all Inkscape windows and restart the program to be able
to select the new font.

The tab Variants allows you to activate specific features of certain fonts, like ligatures.

There are several options that influence the text’s orientation. Inkscape offers support
for vertical scripts, and also for text that is written from right to left, like Arabic or
Hebrew. If your screen isn’t wide enough to display the whole list of option buttons for
the Text tool, you will see a little arrow on the far right of the tool controls bar. Click
on it to reveal the missing options.

154



, Release 1.0

Fig. 1: The text tool’s options

Fig. 2: Font tab of the Text and Font dialog
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Fig. 3: Text tab of the Text and Font dialog
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FORTYFOUR

CHANGING TEXT COLOR

You can change a text’s color the same way as you change the color of any vector object
in Inkscape. First, you need to select the text, or, using the Text tool, you can even
select words or characters in a text, then you click on the color of your choice. The text
can have a separate paint for fill and stroke, like all the objects in Inkscape. You can
also apply a gradient to a text.

Fig. 1: Text variations
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FORTYFIVE

MOVING AND ROTATING LETTERS

Aside from deforming a text with the Selector tool, Inkscape offers numerous options to
have fun with texts, adapting them to the design, while keeping them editable.

To use the following options you need to select the text, words, or letters you want to
move with the text tool, and then increase or decrease the value of the option in the
tool controls bar (the default value for all of them is 0). The change will immediately
be visible on the canvas.

45.1 Options for moving and rotating letters

45.1.1 Changing spacing between letters

The option allows you to change the distances between all letters in the selected text,
or the selected letters. This is useful if your font size is very small, because it improves
readability.

45.1.2 Changing spacing between words

Here you can change the distances between all words in your text, or the selected part
of the text.

45.1.3 Changing horizontal kerning

The option changes the distance between the two letters in the position of the cursor.
All letters that come after will move by the value you indicate in the input field.
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45.1.4 Changing vertical kerning

One of the options is for changing the position of a word or single letters in relation to
the base line. This means that the selected word or letter will be moved up or down,
and will no longer rest on the same line as its fellows.

45.1.5 Changing letter rotation

One last option allows you to also rotate single letters (or all selected letters).

If your design requires a more radical change of the shape of the text, it is possible to
make a text follow a path or to put it into an arbitrarily shaped frame.

Fig. 1: Options of the text tool that change the letters’ positions.

Fig. 2: Standard text.

Fig. 3: Text with a little kerning added.

45.1. Options for moving and rotating letters 159
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Fig. 4: Text with exaggerated kerning and rotation.

45.1. Options for moving and rotating letters 160
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FORTYSIX

PUTTING TEXT ON A PATH

The adjustment of letters’ and words’ positions are merely the finishing touch. More
often, it is useful to start out by layouting the text as a whole in a drawing. Inkscape
offers two options for this, which are accessible via Text → Put on Path and Text → Flow
into Frame.

To make a text that follows a path’s curvature, you need to do this:

1. Create a path that will serve as the base line for the words and letters of the
text. The path can be created by using the shape tools and combining shapes with
the Boolean operations, or by drawing it directly with one of the tools that draw
paths.

2. Write the text directly on the canvas, after clicking on it with the mouse. It’s not
useful to use flowed text in a frame for this.

3. With the Selector tool, select the path and the text. Then make Inkscape do the
work by selecting Text → Put on Path from the menu.

The result will show up on the canvas immediately. The text can still be edited at any
time: you can change its contents or style whenever you like. The path will remain
editable, too: you can shape its curves, add or delete nodes, move it, etc. and the text
will automatically adjust to its changed shape.

Very often, this path only serves to position the text. If you delete it, the text doesn’t
have anything to follow anymore, and reverts to its previous shape. If you don’t want
to see the path in your drawing, remove its fill and its stroke!
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Fig. 1: Create a text and a path by whichever method you prefer. . .

Fig. 2: . . . and put the text on the path using Text → Put on Path.
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FORTYSEVEN

FLOWING TEXT INTO A FRAME

Whether you’re creating a graphical poem (calligram), or whether your text needs a
specific shape to fit into your layout, Inkscape offers you a tool to assist with this type
of design.

To use it:

1. Write the text on the canvas (or copy-paste it).

2. Create the path or shape that the text is supposed to fill.

3. With the Selector tool, select the shape and the text, then use Text → Flow into
Frame.

The path stays editable, the text will try to fill it as good as possible. The text, too, can
still be edited any time.

Very often, this is just the first step in arranging a text in a decorative fashion. Some
finishing touches may be needed to improve the positioning of certain words or letters,
by using the options offered by the Text tool.

To further tweak the text, there is one last, irreversible option: the transformation of
a text into a path. When you convert a text into a path, you will lose any possibility of
editing the text’s contents. The text will no longer be available as a text object, but it
now allows you to use all the available options for editing paths. For example, it will
become impossible to change the font, the font weight (light, bold, heavy,. . . ) or the
style (italic, regular, condensed,. . . ). Because of this, it is recommended to work on the
rough and general shape of a text first, and to later move on to the finer details:

• Finish everything that needs to be done with the Text tool, to benefit from the
tool’s property of keeping the text itself editable.

• Only convert the text to a path at the very end, to be able to tweak the small
details of the text.

If you would like to share the SVG file on the web, or to export it into a PDF file, that
you want to share with other people, convert all text objects to paths. Not all computers
have the same fonts installed, and the file may look very different to someone, if their
computer uses a fallback font to display the text.
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Fig. 1: The shape of the octopus will act as a container.
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Fig. 2: Text flowed into a frame that resembles an octopus.
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CREATING CUSTOM FONTS

Fonts can be saved in different file formats: OTF, TTF and SVG (and some more).

With Inkscape, you can create SVG fonts.

These fonts are embedded in the resulting SVG file. For being able to use them in a text
editor or graphics program, however, they must later be converted to another font file
format.

You will not be able to use the SVG file directly as a font in a webpage, for instance.
This is because SVG fonts have been removed from the official SVG standard. However,
they are useful for font-making in Inkscape, and other font-making programs can still
convert them to other font file formats.

The letters, numbers and special characters a font consists of are called glyphs.

To create a your custom SVG font:

1. Open the typography template with File → New from Template → Typography
Canvas.

2. Open the Font Editor dialog from Text → SVG Font Editor.

3. In the column labelled Font, click on New to create a font. You can double-click
on the generic name, in this case font 1, of the font to change it.

4. Open the Layers dialog from Layer → Layers.

Tip: You can also use the Layers dialog button in the commands bar.

Repeat the following for each glyph that you want to add to your font:

1. In the Layers dialog, add a new layer by clicking on the ‘+’ icon. Name it after
your letter. Select the layer in the dialog.

2. Now, in the Font Editor, in the tab Glyphs, click on Add Glyph. Double-click on
the Glyph name field to name your glyph, e.g. call it ‘Capital A’ or ‘Space’. In the
Matching String field, enter the letter that it corresponds to.

3. Draw the path for your glyph on the canvas. It must be a closed, single path,
which may consist of multiple subpaths.
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4. When you’re happy with your glyph, select it, and also select the corresponding
row in the dialog, then click on Get curves from selection.

Tip: You can always test your font by typing a text into the field at the bottom of the
SVG Font Editor dialog and looking at the preview above it.

Hint: You can use the little ‘eye’ icons in the Layers dialog to hide the layers with
the glyphs that you have already finished. To protect the completed glyph layers from
accidental changes, use the ‘lock’ icons.

When you are done making the glyphs, save the file as an Inkscape SVG (this is
Inkscape’s standard file format).

Although this functionality is meant for typographers, amateurs, too, can quickly get a
working result and test their work as they continue.

When your font is finished, you can use a font-making software like FontForge where
you import your SVG font and can export it into other different formats to be able to
use it with other software, like Microsoft Word, LibreOffice, in any other program that
supports the choice of fonts, or in a HTML file using CSS.

Fig. 1: The typography template has just the right size for a single letter. It comes with
5 useful guides for making your font. On the right side, the (lowercase) letter ‘a’ has
already been added to the SVG font.
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FORTYNINE

SAVING YOURWORK

Inkscape is stable software. However, some unfortunate actions can entail a crash.
The best way to prevent this from causing problems is to regularly save your drawing.
For this reason, the keyboard shortcut Ctrl + S should be used frequently. When you
first save your drawing, give your file a name of your choice, and select one of these
extensions:

.svg (Inkscape SVG)
to keep all the data in your file, even the data that is only useful for editing with
Inkscape, and no other editor

.svg (Plain SVG)
for sharing your drawing with other people, who might not use Inkscape, but use
SVG, e.g. when they view a web page that uses a picture that you created

.svgz (compressed Inkscape / Plain SVG)
compressed to save space on your harddisk

49.1 Activating Autosave prevents loss of work

If Inkscape closes unexpectedly, in most cases, it creates a backup file, which is avail-
able in a location that will be indicated in a dialog window. The file name consists
of the original file name with the time and date of the crash. It is recommended that
(additionally to saving frequently) you activate Inkscape’s Autosave feature, which you
can find in Edit → Preferences → Input/Output → Autosave.
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EXPORTING A PNG FILE

Often, it’s useful to export your work into a raster graphics file format, to show off or
use it with other programs.

Open the dialog Export PNG Image with Shift + Ctrl + E, or by going to File → Export
PNG Image. Now you will have a couple of different options for the export area:

• Page: Export only the contents of the page area

• Drawing: Export all objects that you have drawn on the canvas

• Selection: Export only the area of the selected objects

• Custom: Export according to the coordinates that you enter into the fields at the
top

Under the heading Image Size, indicate the size of your image in pixels, or the de-
sired resolution. The other values will adapt automatically. Now select a name for the
exported file and click on Export.

Beginners are sometimes surprised that their exported image has a transparent back-
ground. To change this, open File → Document Properties (Shift + Ctrl + D), then for
a white background, set the alpha channel of the background color to 255 after a click
on the Background Color field. Other colors can be selected for the export background
accordingly.

Inkscape exports your drawing without a margin. This can lead to the impression that
the image is cut off, while it is not. If this bothers you, you can add margins by using
the collapsible field Resize Page to Content in the first tab of the Document Properties
dialog. Note that this changes the page size.
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Fig. 1: PNG image export dialog
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Fig. 2: Changing the settings in Resize Page to Content
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EXPORTING A PDF FILE

The PDF file format is a vector format that can also hold raster images. Inkscape can
save directly to PDF. To do so, do File → Save a Copy, and select Portable Document
Format (*.pdf) from the list of available file formats at the bottom.

Caution: Never save as PDF only, but always keep an SVG file, because the PDF
file format supports a different set of features from the SVG file format and you may
lose data in the process.

A dialog will then allow you to set the following options:

• Restrict to PDF version: Current choices are 1.4 or 1.5. If no specific version is
required by the persons who will get the PDF file from you, you can leave it at the
default 1.5.

• Text output options: If your text needs to be searchable in the PDF and the font
license allows you to embed the font, choose to Embed fonts. When the text is
mostly decorative (as in a logo), it’s better to convert the text to paths. If you’re
writing on a thesis or another scientific document, and know how to work with
LaTeX, you can make use of the third option Omit text in PDF and create LaTeX
file.

• Rasterize filter effects: Blurs, shadows and any other filters cannot be used in PDF.
This option tells Inkscape to make a ‘photo’ of any objects/areas in the drawing
that have a filter. That way, the drawing will still look the same in a PDF. If you
do not select this option, objects that are filtered will look different in the PDF.

• Resolution for rasterization (dpi): The higher the value, the more fine-grained the
‘photos’ of filtered objects will be. Common values are 96 dpi for screen display,
and 300 or 600 dpi for printing.

• Output page size: Lets you choose which part of the drawing to export to PDF.

• Bleed/margin: Increases the size of the exported area by adding a margin of the
selected width.

• Limit export to object with ID: Only export the specified object.

Tips
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Fig. 1: The PDF export dialog offers many options. Usually, the default settings will
work fine. However, when the PDF is for printing (as opposed to screen display), it is
recommended that you set the dpi value (resolution) for filtered objects to at least 300.

• In Inkscape 1.2, this is the only way to export all pages of a document into a
single, multi-page PDF file.

• Inkscape can also open PDF files for editing. Try to avoid multiple round-trips
through different file formats, though, because each conversion loses data or adds
unnecessary data.

• Note that for creating perfect PDF files for printing, it’s better to turn to a ded-
icated desktop publishing software such as Scribus, which can also import SVG
files.
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FIFTYTWO

EXPORTING TO OTHER FILE FORMATS

In addition to PDF and PNG, Inkscape can export to a variety of other file formats. A
list of available formats in your own Inkscape installation can be found at the bottom
of the File → Save, File → Save as and File → Save a Copy dialogs.

Some formats only become available when a certain other program is installed on the
computer. Third-party Inkscape extensions that you install yourself can also add new
file formats to the list.

No matter which format you want to export to, it is recommended to only use the Save
a Copy functionality for this, and to save your original file as Inkscape SVG. This way,
you can always come back and make edits to your original drawing, and you will not
lose helpful editor data, such as guides, grids, path effects, layers and more.

For some of these file formats, you will get a dialog prompting you to select further
options for export.

Note that most export file formats do not support all Inkscape features.

52.1 Commonly available export file formats

(ordered by file extension)

Desktop Cutting Plotter (AutoCAD DXF R 12) (*.dxf)
plotter file format

Desktop Cutting Plotter (AutoCAD DXF R 14) (*.dxf)
plotter file format

Enhanced Metafile (*.emf)
improved version of .wmf with support for Bézier curves

Encapsulated PostScript (*.eps)
embeddable printer graphics file

Flash XML Graphics (*.fxg)
XML-based file format (similar to SVG) for use with Adobe Flash and Adobe Flash
Player
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GIMP Palette (*.gpl)
color palette containing the colors used in the current document that can be used
by several open graphics programs, such as Gimp, Inkscape or Krita

HP Graphics Language plot file (*.hpgl)
plotter file format

HTML 5 canvas (*.html)
HTML5 canvas object

OpenDocument drawing (*.odg)
open diagram file format, for use e.g. with LibreOffice

Portable Document Format (*.pdf)
standardized document exchange file format

PovRay (*.pov) (paths and shapes only)
file format for a 3D ray tracing software

PostScript (*.ps)
printer graphics language file format

Synfig Animation (*.sif)
Synfig animation canvas file format

Optimized SVG (*.svg)
SVG file optimized for size

Plain SVG (*.svg)
SVG file that does not contain any editor data

Compressed Inkscape SVG (*.svgz)
gzip-compressed SVG file with all editor data

Compressed plain SVG (*.svgz)
gzip-compressed SVG file without editor data

Layers as Separate SVG (*.tar)
each layer of the current SVG file saved as a separate SVG, bound together in a
tar archive

LaTeX With PSTricks macros (*.tex)
file format with support for complex math formulas commonly used for generat-
ing and type-setting large scientific documents, like doctoral theses

Windows Metafile (*.wmf)
proprietary Windows vector file format that only supports straight lines

Microsoft XAML (*.xaml)
Microsoft’s graphical user interface description language file format

Jessylnk zipped pdf or png output (*.zip)
JessyInk slide show with one pdf or png file per slide, compressed into a zip file

Compressed Inkscape SVG With media (*.zip)
Inkscape SVG file and linked image files, compressed into a zip file
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FIFTYTHREE

IMPORTING PICTURES INTO A DOCUMENT

Sometimes, it can be necessary to use raster images in your drawing, be it for copying
from a sketch you made, vectorizing a raster image, or for adding a photo into your
design. Depending on the purpose, a raster image can be linked to, or embedded.
Linking to an image means that Inkscape loads the raster image from the place where
it is stored into Inkscape everytime the file is opened. In consequence, if you move or
delete the raster image file or the SVG file, or share the file with someone else, the link
between those two will break. Instead of the image, you will see a red frame. So it is
often safer to embed raster images into the SVG file instead. This will make the file
larger, but your drawing will not change due to moving your files around.

To import an image, use File → Import. In the dialog that opens, you can select the file.

Then a dialog will ask you if you would like to link or embed the image in question.

Don’t panic if you have selected the wrong option for embedding or linking, you can
change this any time. Select the image, right-click on it, and then either select Extract
Image or Embed Image, to change to the other mode.

The imported image will be inserted at your mouse cursor’s position, or, if the mouse is
not currently on the canvas, into the middle of the visible area of your drawing.

Inkscape imports a huge variety of raster image file formats, but only exports to PNG.
There exist extensions for Inkscape that allow to export to JPG and other file formats.
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Fig. 1: Bitmap Image Import Dialog

Fig. 2: When the imported image is only linked in the document, and later moved away,
Inkscape will not be able to find the image. A beautiful red frame with a cross will be
displayed on the canvas instead!
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IMPORTING OTHER FILE FORMATS

Inkscape can import and open a large variety of file formats. The availability of some
import file formats depends on other programs installed on your computer. Third-party
Inkscape extensions can be used to import additional file formats.

When you import certain file formats, Inkscape may open a dialog asking you to specify
import options for the file.

For some file formats, Inkscape is only able to import a subset of all available features
of that file format.

54.1 Commonly available import file formats

(ordered by file extension)

Adobe Illustrator 9.0 and above (*.ai)
Adobe Illustrator files created with Illustrator 9.0 and newer

Adobe Illustrator SVG (*.ai.svg)
SVG file exported from Adobe Illustrator

ani (*.ani)
file format for animated mouse cursors on MS Windows

wmf (*.apm)
same as Windows Metafiles (*.wmf)

bmp (*.bmp)
Windows Bitmap image file format

Corel DRAW Compressed Exchange files (*.ccx)
Corel DRAW exchange file format

Corel DRAW 7-X4 files (*.cdr)
Corel DRAW file format version 7-X4

Corel DRAW 7-X4 files (UQ) (*.cdr)
Corel DRAW file format version 7-X4

Corel DRAW 7-13 template files (*.cdt)
Corel DRAW template file format version 7-13
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Corel DRAW 7-13 template files (UC) (*.cdt)
Corel DRAW template file format version 7-13

Computer Graphics Metafile files (*.cgm)
standardized graphics format for vector and raster data

Corel DRAW Presentation Exchange files (*.cmx)
Corel DRAW exchange file format for presentations

Corel DRAW Presentation Exchange files (UC) (*.cmx)
Corel DRAW exchange file format for presentations

ico (*.cur)
non-animated cursors file format for MS Windows

ACECAD Digimemo File (*.dhw)
ACE CAD digital notepad notes file

Dia Diagram (*.dia)
Diagram file format from Dia

AutoCAD DXF R13 (*.dxf)
dxf CAD file format from AutoCAD, version 13

Enhanced Metafiles (*.emf)
proprietary Windows vector file format that only supports straight lines

Encapsulated PostScript (*.eps)
embeddable printer graphics file

GdkPixdata (*.gdkp)
pixel data files for GTK

gif (*.gif)
graphics interchange format, a common raster file format (animations not sup-
ported in Inkscape)

GIMP Gradient (*.ggr)
gradient file from Gimp, gradient will be available in the Fill and Stroke dialog

HP Graphics Language file (*.hpgl)
plotter file format

icns (*.icns)
Apple icon image file format

ico (*.ico)
Windows computer icon file format

jpeg2000 (*.j2k)
see *.jp2

jpeg2000 (*.jp2)
standardized compressed raster image file format

jpeg2000 (*.jpc)
see *.jp2
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jpeg (*.jpe)
see *.jpeg

jpeg (*.jpeg)
Joint Photographic Experts Group compressed raster image file format

jpeg (*.jpg)
see *.jpeg

jpeg2000 (*.jpf)
see *.jp2

jpeg2000 (*.jpx)
extended jpg2000 file format, see jp2

pnm (*.pbm)
portable bitmap file format (black and white only)

pcx (*.pcx)
ZSoft picture exchange raster graphics file format

pnm (*.pgm)
portable graymap file format (grayscale)

Adobe PDF (*.pdf)
standardized document exchange file format

HP Graphics Language Plot file [AutoCAD] (*.plt)
plotter file format

png (*.png)
portable network graphics, a lossless raster image file format

pnm (*.pnm)
portable anymap file format (see also pbm, pgm and ppm)

pnm (*.ppm)
portable pixmap file format (RGB)

PostScript (*.ps)
printer graphics language file format

qtif (*.qif)
see *.qtif

qtif (*.qtif)
Quick Time image file format

ras (*.ras)
Sun (Solaris) raster file format

Scalable Vector Graphic (*.svg)
SVG files, such as the files Inkscape generates

Compressed Inkscape SVG (*.svgz)
gzip-compressed SVG file with all editor data
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tga (*.targa)
see *.tga

tga (*.tga)
Truevision Advanced Raster Graphics Array image file

tiff (*.tif)
see *.tiff

tiff (*.tiff)
Tagged Image File Format (raster file format)

Microsoft Visio 2013 drawing (*.vsdm)
drawings created in MS Visio 2013

Microsoft Visio 2013 drawing (*.vsdx)
drawings created in MS Visio 2013

Microsoft Visio XML Diagram (*.vdx)
diagrams created in MS Visio

Microsoft Visio Diagram (*.vsd)
diagrams created in MS Visio

Windows Metafiles (*.wmf)
improved version of .wmf with support for Bézier curves

WordPerfect Graphics (*.wpg)
graphics exported from Word Perfect

Microsoft XAML (*.xaml)
Microsoft’s graphical user interface description language file format

xbm (*.xbm)
X BitMap file format for cursors (black and white)

xpm (*.xpm)
X PixMap file format for cursors (color, successor of *.xbm)
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FIFTYFIVE

OVERVIEW

Now you have familiarized yourself with the basics of the Inkscape program. While
Inkscape may appear complex when you first use it, with some practice, you will soon
feel more confident.

In this chapter, you will discover functionality that can be used to automate or simplify
many steps. However, don’t forget that originality comes from your imagination, and
not from a software that autogenerates the results for you.

First, we will learn about some useful techniques, then we will get to see some interest-
ing filters, extensions and path effects. Lastly, you will learn a little about customizing
Inkscape.
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FIFTYSIX

COPYING AND DUPLICATING OBJECTS

The famous Copy keyboard shortcut Ctrl + C also works in Inkscape, but its brother
Duplicate, with Ctrl + D is very useful, too.

Copying with Ctrl + C copies the selected element into the clipboard. It can then be
pasted into the document (or into another open document) by using the corresponding
shortcut Ctrl + V. This inserts the object at the place of the cursor.

Duplicating, however, makes a copy of an object and positions this copy exactly on top
of the original. This can be very useful when your copy needs to be in the same place
as the original—you will not need to use the mouse or the alignment functions to move
it back.
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FIFTYSEVEN

CLONING OBJECTS

Alt + D Edit → Clone → Create Clone

You can save yourself some time when you know how to use clones. With Alt + D,
a clone can be created just as quickly as a copy or a duplicate. One only needs to
remember that the option exists.

The new clone will appear right on top of the original, and will follow all modifications
made on the original, no matter if they affect its style (stroke, fill,. . . ) or its shape.

The clone’s shape cannot be edited directly. Its colors can only be changed if the original
has no color itself. Its size and rotation can be changed freely.

Tip: To remove a color from an object, you must ‘unset’ its paint, using the question
mark button in the Fill and Stroke dialog.

To turn a clone into an independent, fully editable object, you need to unlink it from
its original with Shift + Alt + D, Edit → Clone → Unlink Clone or by clicking on the
corresponding icon in the command bar.

To select the original of a clone, you can press Shift + D or use Edit → Clone → Select
Original in the menu.
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Fig. 1: All these stars are clones of the star in the top left corner. They have the same
color and shape, but different sizes and rotations. Note that the selected clone does not
have any star tool handles.
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FIFTYEIGHT

GROUPING OBJECTS

Grouping

Shift + Ctrl + U or Ctrl + G, Object → Group

Ungrouping

Shift + Ctrl + G or Ctrl + U, Object → Ungroup

Grouping allows you to work with multiple objects as a single object: any changes
you make will equally affect all members of the group, and the entire group can be
copied, duplicated or cloned as a unit. Grouping your objects can help keep your
canvas organized; for instance, if you’ve positioned several shapes in a nice even row,
grouping them together will make sure that none of them become offset. Groups can
also be nested within other groups.

58.1 Adding objects to a group

To demonstrate, consider a simple smiley face made of four objects: a big yellow circle,
two black ellipses, and a curved line:

Since we don’t want the eyes to get out of alignment, we should group them. Select
both objects and then select Group from the commands bar, Object menu or keyboard
shortcut:

Note that we could also, if we wanted, group all four objects together at the same time.
In this example, we’ll make three nested groups: one of the eyes, another of the face
(mouth + eye-group), and a third of the whole head (head + face-group):
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Now the smiley face can be moved, rotated, and scaled as a single object.

58.2 Manipulating objects within a group

When you Enter a group, you gain the ability to select and manipulate its elements
freely. To Enter a group you can either:

• Double-click on the group

• Right-click on it and select Enter group from the dropdown menu.

• Left-click once on the group and press Ctrl + Enter

Remember that groups can be nested! You may need to Enter multiple levels of groups
before you reach the object you’re looking for.

When you’re done editing objects within a group, you need to Exit back out. To Exit a
group you can either:

• Double-left-click anywhere outside the group

• Right-click on the group and select Go to parent from the dropdown menu.

• Left-click once on the group and press Ctrl + Backspace

Note that there is no indicator on the canvas of which group you are “in” at any given
time (other than the feedback of which objects you can and cannot select individu-
ally). To find that information, look at the status bar or the Objects dialogue (Object →
Objects. . . )
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58.2.1 Manipulating objects without entering a group

You can select and edit any individual item within a group, without either first entering
or ungrouping said group, by holding Ctrl while left-clicking it. Note that this will
select an item no matter how many nested groups “deep” it is – for example, in the
smiley face up above, Ctrl + clicking on one of the eyes would allow you to move it,
even though it’s within a group within a group within a group.

• Note that moving or manipulating an item in this way does not remove it from its
group – once you release your selection, any further transformations of the group
will continue to affect the object as before.

If the object you want to select is “underneath” another object, repeatedly pressing
Ctrl + Alt + left click will cycle through ALL objects in that location (high to low in
z-order). Having the Object Properties tab open ( Shift + Ctrl + O ) can help to keep
track of which object you’ve currently selected.

58.3 Removing objects from a group

To remove objects from a group you can either disband the entire group or pull one
object out to the next level up.

To disband (“ungroup”) a group, you can either:

• Select the group and choose Object → Ungroup from the menu bar or the Ungroup
icon from the commands bar

• Right-click on the group and choose Ungroup from the dropdown menu

Ungrouping returns all objects in the group to the next level up. If you want to extract
only a single item while leaving the rest of the group in place, you need to first Enter
the group. Then, either:

• Select the object you wish to extract and choose Object → Pop Selected Objects out
of Group from the menu bar

• Right-click on the object and choose Pop selection out of group from the dropdown
menu

Note that this will only move the object up one level higher – if you have multiple
nested groups, you may need to repeat this process multiple times until the object is
extracted to the desired level.

58.3. Removing objects from a group 188



CHAPTER

FIFTYNINE

ALIGN AND DISTRIBUTE

Shift + Ctrl + A

This dialog offers invaluable help. You can use it to align nodes and objects vertically
or horizontally, or to distribute them at equal distances.

To use it for aligning nodes:

1. Open the dialog by clicking on its icon in the command bar to the right of the
canvas.

2. Switch to the Node tool.

3. Select a couple of nodes.

4. Click on the node alignment button of your choice. The alignment will be applied
immediately.

To align objects:

1. Open the dialog.

2. Switch to the Select tool.

3. Select the objects that you want to align.

4. Decide which one of the objects should not move at all. The object you selected
first? The one you selected last? The biggest or the smallest one? Or perhaps you
want to move all the objects in relation to the page? In the dropdown labelled
Relative to:, select the option that applies.

5. Click on the alignment button of your choice. Use the tooltips that display when
you hover over them with the mouse to learn what each symbol means. The
selected alignment will be applied immediately.
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Fig. 1: Before arranging the objects, they are distributed somewhat randomly on the
canvas.
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Fig. 2: After aligning each row and column vertically and horizontally, the result looks
very neat.
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Fig. 3: With the Align and Distribute dialog, it only takes a couple of clicks to arrange
your objects neatly.
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SIXTY

TRACING AN IMAGE

Shift + Alt + B, Path → Trace Bitmap

You can use this feature to turn a raster image to paths that you can use and edit in your
design. This process is called ‘Tracing’ or ‘Vectorization’. If you expect a 100% faithful
representation of your picture, though, only in vector format, you will be disappointed.

The functionality is ideal to vectorize dark silhouettes in front of a bright background.
There is an option for keeping colors, but Inkscape will then create one object for each
color. You’ll find yourself facing a pile of objects, each of a different color. This can be
difficult to edit, especially for a beginner.

To vectorize a picture:

• Import a suitable bitmap image by using the menu File → Import.

• Select the image with the Selector tool.

• In the menu, go to Path → Trace Bitmap.

• A dialog will open where you can set different options.

• Use the Update button to get a new preview image whenever you change the
settings. When the result of the preview looks right, click Ok. The vectorized
image will be available right on the canvas. It will be positioned exactly above
your picture.

Tip: Sometimes, the vectorized version will be so similar to the original bitmap image,
that you do not notice a difference. Use the Selector tool to move it to a different place
on the canvas, so you can examine it properly.

Let’s take a closer look at the options for this wonderful tool. The first tab offers several
different choices in the Single scan tab:

Brightness cutoff
This is the most frequently used mode. It will create a silhouette-like path that
follows the shape of your image.

Edge detection
Useful if you only want to vectorize the contours of a shape.
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Color quantization
This traces along borders between different colors.

Autotrace
Like Brightness cutoff, this will also trace the outlines of objects in your image.
You can ignore it for now.

Centerline tracing (autotrace)
This mode will reduce a shape to an open path. It is best used with handwritten
text and other line drawings.

Fig. 1: The results of tracing the letter on the left with Brightness cutoff (center) and
Centerline tracing (right).

Don’t forget to refresh the preview on the right of the dialog, and to click on Apply to
create the vector object.

Fig. 2: rocket.png, the image that we want to trace in this example.

The mode Multiple scans will give you a more detailed result, but it will create a separate
object for each scan.
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Fig. 3: The image rocket.png has been imported and the Trace Bitmap dialog was
opened.
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Fig. 4: The rocket traced with the Brightness cutoff option.
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Fig. 5: The rocket vectorized with the Edge detection option.

Fig. 6: A bitmap image in color.
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Fig. 7: Multiple scans: Colors option with 10 scans. There are 10 stacked objects in the
result.

Fig. 8: After ungrouping, the 10 objects can be moved.
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SIXTYONE

CLIPPING ANDMASKING

These two features are both employed in the same way: put the object that will serve
as clip (or mask) above the object that you want to clip (or mask). Then select both
objects, and use Object → Clip → Set or Object → Mask → Set. The top object will then
become invisible and work to hide parts of the bottom object.

Clips and masks give different results. A clip allows you to hide all parts of the bottom
object that are outside the clip object. The colors of a mask object affect the opacity of
the bottom object. The darker and the more transparent the mask, the more transparent
the masked object will become. A white mask works just like a clip.
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Fig. 1: The object we want to clip and mask
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Fig. 2: The path for clipping (and masking) has been positioned above the head of the
griffin.

Fig. 3: On the left, the griffin’s head was clipped with the circle. On the right, the circle
was used as a mask.
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SIXTYTWO

FILTERS

One of the menu entries is dedicated to filters. More precisely, all of these are combi-
nations of SVG filters. The possibilities of combination are infinite, and the Inkscape
developers put some combination suggestions into the menu and tried to find a descrip-
tive name for each.

To apply a filter, you need to first select one or more objects, then select the filter you
want to use. The result will immediately be available on the canvas.
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62.1 The Drop Shadow Filter

This filter promises to automatically add a shadow to the selected object that will be
placed below the object. First, select one or more objects, then open the filter’s dialog
with Filters → Shadows and Glows → Drop Shadow.

The dialog allows you to define the amount of blur, the shadow’s offset, it’s type, and its
color. The larger the blur radius, the more distant will the object seem from its shadow.
The farther away the values for the x and y offset are from 0, the more will it look as if
the light comes from the side.

The dropdown for the shadow type allows you to choose between:

• Outer: normal shadow

• Inner: the object looks like it were a hole

• Outer Cutout: just the outer shadow, the object will be invisible

• Inner Cutout: just the inner shadow, without the object

• Shadow Only: the full shadow, without the object

In the Blur color tab, you can change the shadow’s color and opacity (the intensity of
the shadow).

If you want to play with different values, check the little box labelled Live Preview, then
the result will be shown on the canvas. It will only be applied to the object when you
click Apply.
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62.2 Editing Filters

Inkscape offers a dialog for editing filters, which can be opened from the entry Filter
Editor at the bottom of the Filters menu.

When the dialog opens, and there is no filter applied to the currently selected objects,
it will be empty. When there is an object with a filter selected, you will see the compo-
nents of the object’s current filter.

The basic principle of the dialog is simple, but understanding all its ramifications is
highly complex. One needs to have a deep knowledge in SVG filters and matrix math-
ematics to be able to understand how to use the parameters of every available filter to
achieve a specific result.

Because of this, the easier option may be to just play with the filter settings randomly,
starting from one of the stock filters that is similar to the desired result.

Here is a list of some interesting filters:

• Distort → Chalk and Sponge: turns objects into an interesting explosion.

• Image Paint and Draw → Pencil: converts the selected objects to a sketch.

• Scatter: Several filters that give different scatter effects.

• Blurs: Offers several blur variations.

• Morphology: Offers filters that have to do with the objects’ contours.

It’s up to you to explore this further. The result of most filters depends heavily on the
selected objects.
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SIXTYTHREE

EXTENSIONS

In this submenu, you will find functionality that does not target Inkscape’s main objec-
tive, but that has still been accepted into the Inkscape program by its developers.

They are grouped into some very distinct categories:

• Arrange: Affects the stacking order and grouping of objects.

• Color: Affects only the color of the selected objects.

• Document: Changes and informs about specific document properties.

• Export: Offers exporting functionalities and export preparation.

• Gcodetools: For generating GCode and communicating with cutting machines.

• Generate from Path and Modify Path: These extension scripts need a path to start
with, so they can create something from it.

• Images and Raster: Both of these categories affect raster images that are linked or
embedded in the SVG file.

• JessyInk: For creating animated presentation slides.

• Render: Generates new objects on the canvas.

• Stylesheet: Associates your SVG with the web design.

• Text: Offers additional functionalities for working with text.

• Typography: For quickly creating SVG fonts (independently from SVG Font Edi-
tor).

• Visualize Path: Offers multiple options to visualize different properties of a path.

• Web: Allows you to add some simple Javascript or do some layouting for the web.

We will now take a closer look at some of the extensions.

205



, Release 1.0

206



, Release 1.0

63.1 Some Very Useful Extensions in Detail

63.1.1 Interpolate

This extension draws the steps that convert one path into another one. Start by cre-
ating a first path, and then another one that is the goal of the transformation. Select
both paths and open this extension’s dialog with Extensions → Generate from Path →
Interpolate. It will ask you for the number of steps you want to generate. When you hit
Apply, the result will appear on the canvas. It consists of a group of as many paths as
you have indicated for the Steps value. The paths will all have the same style. You can
ungroup them, when you want to edit each path separately and customize their styles.
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63.1.2 Pattern along Path

This extension chains copies of an object, so they follow the curvature of a path that you
have drawn. First draw your path. You can use the Pen/Bézier tool for this. Then create
your pattern. The pattern can be a path, even one that consists of multiple subpaths,
and even a group.

Make sure that your pattern is on top of the path in the stacking order. Select the two
objects, then open the extension dialog with Extensions → Generate from Path → Pattern
along Path.

The dialog will ask you to decide whether the pattern should be repeated as many times
as possible on the path, or if it should be stretched, to start at the path’s start, and end
exactly at its end point (and not after that). The deformation type option allows you to
select whether to simply chain the objects, or to make them look like they are printed
on a ribbon. The other options are about adjusting the objects’ position in relation to
each other and to the path.
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63.1.3 Color Markers

This extension allows you to edit the color of object’s markers. They can either be
adapted to fit the object’s colors (which is the default), or you can select a specific
color yourself. You need to select the path with the markers that you want to change,
then open the dialog with Extensions → Modify Path → Color Markers. When you have
selected the options you need, click on Apply.
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63.1.4 Edge 3D

After having selected a path, you can open the extension’s dialog with Extensions →
Modify Path → Edge 3D. As Inkscape is a 2D software, the 3D effect can only be sim-
ulated. You can refine the 3D illusion by adjusting the values for the blur, the lighting
angle and the width. The preview is very useful for tweaking the result. Hit Apply when
you are satisfied with what you see.
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63.1.5 Envelope/Perspective

These extensions allow you to automatically deform a path to meet a perspective or to
fit into a 4-sided shape, which you indicate by drawing a rectangular shape.

For example, you may have drawn a piece of furniture in a room in perspective, and
now you would like to put a design onto its faces. Draw a rectangle in the shape of the
furniture’s face.

Then use the extension with Extensions → Modify Path → Envelope or Perspective. Now,
the path will be deformed to fit the selected frame.

Note that this extension will only work with paths

63.1.6 Barcode

This set of extensions that you can find under Extensions → Render → Barcode allows
you to create lots and lots of different barcodes, QR codes and even data matrices. You
only need to enter your numbers or texts, and Inkscape will do the rest for you.
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63.1.7 Printing Marks

If you would like to get your design printed and you need the typical printing marks,
then this extenstion, which you can find at Extensions → Render → Layout → Printing
Marks will be tremendously useful.

You can select the kind of printing marks that you need (crop marks, registration marks
etc.), and the extension will do the rest for you.
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63.1.8 Text

In this category, we can see the extension labelled Lorem Ipsum, which is a generator
for placeholder texts. When you open the extension’s dialog, it asks you to indicate
the number of paragraphs and sentences, and the amount of length difference between
single paragraphs. ‘Lorem Ipsum’ is a pseudo-Latin text, which can be used to fill the
text boxes in your layout with a placeholder text. The generated text will be placed at
the top of the page.
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63.1.9 Installing Extensions

It is easy to install extensions created by the community, or, for those who know how
to write in the Python programming language, to write their own. To learn more about
the inner workings of Inkscape extensions, visit the Inkscape website.

Many extensions can be found in the website’s gallery.

Note that these extensions are not curated, and that many extension developers choose
to publish their extension on other websites.

Generally, to install a new extension, you need to download and unpack its files. Copy
the files into the directory listed at Edit → Preferences → System: User extensions. After
a restart of Inkscape, the new extension will be available. Some extensions may come
with different installation instructions.

A couple of extensions may depend on other programs, that will need to be installed
on your computer for them to work correctly. Usually, the author of the extension will
provide instructions for this.
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LIVE PATH EFFECTS

Live Path Effects (or LPEs) in Inkscape can be used to create new exciting objects from
paths and groups, without destroying the original paths.

They can be selected and adjusted in the Path Effects dialog, which you can access as
Path Effects from the bottom of the Path menu entry.

Each type of path effect has its own, unique set of options in this dialog, and most of
them can also be manipulated by dragging the effect’s handles with the Node tool on
canvas.

Path effects can also be stacked. So you could, for example, first roughen the outline of
a path, then arrange copies of the path around a circle, and then align dozens of those
circles of the roughened paths in a grid.

At any time you wish, you can still edit the shape of the underlying path object, and all
the stacked effects will automatically adjust to the changes.

64.1 Adding a Live Path Effect to a Path

When you don’t have anything selected, the dialog will prompt you to choose a suitable
object (a path, a shape, or a group of paths) before you can proceed. With the object
selected, click on the arrow at the end of the search field in the dialog to see a list of
available path effects, or, if you already know the name of the effect you want to use,
start typing it into the search field. Click on the name of the effect you want to use.

In most cases, the path will already look different from before now.

In the dialog, you will be presented with a list of options for the selected effect. Adjust
those to your liking, and also try out the newly added handles that appear when you
use the Node Tool on an object with a Live Path Effect.
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64.2 Examples

Here’s a description of some of the available LPEs. Don’t hesitate to discover the func-
tionality of the others on your own:

Bend
This effect allows you to take any shape and bend it along a custom path. Useful
for creating custom brushes or deforming objects on a path.

Corners (Fillet/Chamfer)
After you add this effect, you gain the ability to round any corner on your shape.
You can round individual nodes by selecting them and dragging green handles on
the canvas, or you can change values in the dialog.

Hatches
Fills your shape with hatches that can be heavily customized.

Interpolate Sub-Paths
The principle is the same as for the Interpolate extension, but the LPE approaches
the topic differently. It will not create intermediate forms between two different
objects, but only between parts of a single path. You need to combine two paths,
so you have a path consisting of two sub-paths for this effect to work (Path →
Combine or Ctrl + K). Use the options to control the number of in-between steps
and the trajectory along which blending will happen.

Knot
Creates gaps in sections of a path, when they cross with another part of the path.

Mirror Symmetry
This effect mirrors your drawing along an axis of your choice. You could try it
when drawing symmetrical objects like faces, bottles, buildings, or butterflies.

Perspective / Envelope
Seriously helpful for drawing in perspective, thanks to the addition of 4 handles
for the corners that can be moved around to make it look like a flat object is tilted
in 3D space.

Stitch Sub-Paths
This effect is similar to Interpolate Sub-Paths, but it adds perpendicular lines be-
tween two paths.

Pattern Along Path
This LPE’s principle is similar to the extension with the same name. However,
here the pattern parts will all be parts of the same path (and they will always be
distorted to follow the path direction). It can be used like a brush, or just for
adding a repeating edge to any object.

Offset
This effect changes the thickness of the whole object. You can change the offset
(or inset, too!) with a specific value in a panel. Or you can drag on a round
handle on the canvas just using your mouse.
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Power Stroke
Adds handles that allow you to change the width of the path, so it can be different
at different locations along the path.

Rotate Copies
This effect creates many copies of the path or object. It places those copies of the
object around a circle. You could use it for making mandalas, flowers, and other
radial drawings.

Roughen
This effect adds imperfections to your shapes to simulate a more organic drawing.

Sketch
Transforms your path into multiple lines that look like a sketch drawn with a
pencil.

Tiling
This is a very powerful tool for quickly creating and arranging many copies of an
object. It offers options to control the number of clones/tiles in rows and columns,
gaps between them, offsets, size and rotation. There are also 16 different tiling
rules available for you to choose from. This is useful for creating patterns, grids,
and other repeating elements.

64.3 Conclusion

Now we have taken a small tour around many of the effects that add functionality to
Inkscape and allow you to automate specific tasks.

This book is only an introduction to Inkscape. Do not hesitate to further explore the
software once you feel at ease with its basic functionality.
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SIXTYFIVE

CUSTOMIZING KEYBOARD SHORTCUTS

Inkscape allows you to use your own custom keyboard shortcuts. There are various
reasons why you would want to change those:

• you have used a different graphics software before, and would like to keep the
shortcuts the same, so you don’t need to learn so many new ones

• your keyboard layout makes it very hard to press some key combinations

• certain key combinations are already in use on your computer, and you do not
want to change them just for Inkscape

• you want to assign a shortcut to a functionality in Inkscape that doesn’t have a
shortcut by default

You can change the shortcuts at Edit → Preferences → Interface → Keyboard.

The dialog lets you choose between some prefilled keyboard shortcut maps that resem-
ble those of other graphics programs.

In addition to this, you can overwrite any shortcut by:

1. selecting it from the list;

2. clicking on the field in the Shortcut column;

3. pressing the new shortcut, when it says New accelerator in that field. Pressing
Backspace will reset the shortcut to its default value.
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Fig. 1: You can choose between a couple of presets for the keyboard shortcuts.

Fig. 2: When it says ‘New accelerator’, press the new shortcut.
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SIXTYSIX

FINDING HELP FOR INKSCAPE

Inkscape has a helpful and active community. If you find yourself stuck, want to ask for
help or simply wish to connect with others, consider joining the chat or the forum.

If you want to read up on more advanced features of Inkscape, the free online book
Inkscape: Guide to a Vector Drawing Program by Tavmjong Bah (currently covering
Inkscape 0.92, with some parts still documenting older versions) is the standard text-
book on it. There is also a series of tutorials on Inkscape’s homepage.

The keyboard and mouse reference provides an overview of tool and dialog shortcuts
and can help you speed up your workflow.

Taking apart other people’s work can be a good way to learn something. Maybe you
find inspiration while browsing Inkscape’s gallery.

Lastly, if you’re reading the PDF version of this guide, check out Read the Docs for
updates to it.
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DRAW FREELY!
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SIXTYEIGHT

GLOSSARY

Alpha
Value for the opacity of a color, usually between 0 (fully transparent) and 1 (fully
opaque) or between 0% and 100%. Alpha is tied to the color. Independently
of this, each object can have an additional value for its opacity. The opacity
value affects the object as a whole (as opposed to alpha, which affects only the
transparency of the stroke or the fill of the object).

AppImage
A standalone packaging format for programs that run on Linux. AppImages are
(mostly) self-contained executable files, that can be saved anywhere on your com-
puter. To be able to run it as a program, you need to allow your computer to ex-
ecute it by (usually) right-clicking on the file and editing its properties. This may
mean to check a checkbox with the label ‘file is executable’. More information on
the format is availble at appimage.org .

Binary Archive
A folder that contains multiple binary files and requires a special type of program
to interact with them.

Binary File
A type of file which is not meant to be read by humans. It contains no text but
instead is composed of patterns of 0s and 1s that can be directly read by the
computer.

Bit
(Short for binary digit) The smallest unit of data in a computer. A bit has a single
binary value, either 0 or 1.

Cap
The shape that is put on the end nodes of a path. This can be a half circle or a
half square, that is as wide as the path’s stroke. Or the path can just be cut off at
a 90° angle.

Cascading Style Sheets
A way to write out styling information for documents such as HTML and SVG.
The CSS specification is developed by the W3C, just like the SVG file format. CSS
determines how websites look in a browser. For SVG, it is one of two options to
describe how an object is supposed to look.
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Clone
A copy of another object that follows every change made to the original object.
An object can have multiple clones that can all be positioned in different places
in the drawing. Clones can be rotated and scaled independently of the original
object. If the original’s fill or stroke is not set (unset), the clone’s fill (or stroke)
can be edited. In all other cases, the clone’s fill and stroke will look just like the
original’s.

Disk Image (.dmg)
A Disk Image is a special type of file that is commonly used for distributing soft-
ware on macOS. Inkscape and other software applications on the Mac platform
are often downloaded as DMG files. When you open a DMG file, your computer
treats it as though it were a removable drive (hence “disk image”) that you had
plugged into your computer.

Executable File (.exe)
Contains an executable program for Windows and is the standard file extension
used by Windows programs. These are the files that make a program on your
computer run.

Flatpak
A packaging format for Linux programs. Flatpak requires the Flatpak program
for installation and running. It provides a sandbox to isolate the programs run
as Flatpak from other programs on a user’s system, to make running the program
packaged as Flatpak safer for the user.

Flow Text
Text that automatically breaks lines after a given width.

Glyph
A graphical element that represents a specific character (letter, number, punctua-
tion, . . . ) in a specific font.

Hex Color
A way to define a color by 3 numbers in the hexadecimal numeral system, com-
monly preceded by a hash (#) sign. Each number can take on values between 0
(no intensity) and 255 (maximum intensity), or 00 and ff, in hexadecimal. The
first number stands for red, the second for green, and the last for blue. Com-
bined, the colors represent one of the resulting 16,777,216 colors in the sRGB
color space (commonly used for computer screens).

HTML5
The main language that websites are written in, in the (current) 5th edition. Like
SVG, HTML is based on the XML markup structure, consisting of nested elements
that are delimited by angle brackets. HTML is also standardized by the W3C.

Join type
The way that vector path corners look. They can be rounded (round), cut off
(bevel) or pointed (miter).

Ligature
A combination of letters that has its own symbol in a font, mostly for cosmetic
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reasons. E.g. the letters s and t can be contracted to look like they are connected
at the top, or the letters f and i are merged, so that the dot of the i becomes a part
of the f’s upper arc.

Node
A node is a point, placed at a specified position on a path.

Object
An object is any individual drawing component that can have its own set of prop-
erties assigned to it and that can be moved in the drawing as a single entity. An
object could be (to name several examples) a rectangle, a circle, a path, a text, a
group of circles, a clone, or even a group of groups.

Operating System Architecture
A 32-bit architecture means that the operating system is able to process data
chunks up to 32 bits in size. Likewise, a 64-bit architecture means an operating
system can process data up to 64 bits. You need to use the correct program file
for each architecture, otherwise the program won’t work properly.

Note: Most modern computers come as 64-bit systems.

Path
The basic building element in SVG, consists of nodes that are connected by the
segments of the path.

Portable Document Format
A file format abbreviated as PDF which is used for exchanging and printing doc-
uments. Originally developed by Adobe in the 1990s, it has been standardized in
2008 and is now maintained by the International Organization for Standardiza-
tion (ISO).

Pixel
The basic building element of a raster graphic, a dot of a specific color. Also, the
smallest unit that creates a color on a computer screen, commonly consisting of
three little lights, a red one, a green one and a blue one, which, when seen from
a distance by the human eye, mix to look like a single color.

PNG
Abbreviation for ‘Portable Network Graphics’, a standardized raster graphics file
format that supports transparency (unlike JPEG) and that uses lossless compres-
sion (unlike most JPEG images, no compression artifacts) and colors in the RGB
color space.

Portable App
A portable app is a program that does not need to be installed onto a computer.
Instead all necessary files needed to run the program reside in a single folder
located on a disc or USB drive. The advantage to this is that the program can be
taken anywhere the user goes and can be run from the cd or USB drive on any
computer that supports the program. The disadvantages are that the program can
easily be lost and if the USB isn’t properly removed from the computer after use,
the program can get corrupted and stop working.

Personal Package Archive
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A personal repository for Ubuntu packages hosted on Launchpad (abbreviated
as ‘ppa’). Ubuntu’s package management tool ‘apt’ is able to load and install
.deb packages published in a ppa. The Inkscape developers maintain a ppa for
Inkscape.

Scalable Vector Graphics (SVG)
A file format for vector graphics that uses an open standard for saving the image
data in a human-readable plain text format. The structure of the file follows the
tree-like XML structure, similar to HTML (which is used for web pages). There are
various computer programs that can display SVG files (almost all web browsers,
for example), and many programs can save as SVG.

Snap
A packaging format for GNU/Linux programs, developed and promoted by Canon-
ical, the makers of Ubuntu. It uses the package manager Snappy, and is available
for multiple Linux distributions. Due to its strict default safety settings, the format
comes with a couple restrictions for interacting with other resources and devices
on a user’s computer.

Source Code
A set of text files that are written by software developers in one or more program-
ming languages. These files contain the instructions for the computer program. In
order for a computer to be able to execute the instructions, often the source code
must be translated into binary code by a compiler program (‘building’ a program).

Stroke
A contour that is drawn along a vector path or shape. Strokes can have different
widths, colors, patterns (dashes) and even gradients or patterns. Strokes are
optional, not every path / shape has one.

SVG Font
A font whose file format is based on the SVG file format. Inkscape can create SVG
fonts, but cannot use them for writing texts. Another program, like FontForge, is
required to convert the SVG font to a different font file format (e.g. otf, ttf).

XQuartz
An “X11” helper application used to run Inkscape on macOS, in Inkscape 0.92 and
earlier versions. Starting with version 1.0, Inkscape is a native Mac application
that no longer uses XQuartz. XQuartz is an open source X.Org project X Window
System .

Windows Installer Package Files (.msi)
An MSI file is a package that contains installation information for a particular
installer, such as files to be installed and the locations for installation. They can
be used for Windows updates as well as third-party software installers. The in-
stallation results are no different from using an executable file, but msi packages
sometimes do have additional options such as doing silent installations (no hu-
man action needed) or pre-configured installs.

Zip File (.zip)
Zip files are a way to compress large amounts of data into a smaller, more man-
ageable size. This allows for easy transportation and faster downloads of files.
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The disadvantage to zip files is that the files inside need to be extracted and de-
compressed before they can be used.
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ABOUT THIS GUIDE

This book was originally created by Elisa de Castro Guerra, designer and educational
instructor. It was created as a reference guide for learning Inkscape.

It is available under a Creative Commons license (CC BY-SA) and was first published on
TO BE DETERMINED.

The book was translated from French to English in 2016-2017.

The version of the book that you are reading now has been updated and adapted by
Inkscape community volunteers, to match Inkscape 1.1.

We sincerely hope you found this little guide helpful when making your first steps with
Inkscape, and that you will enjoy drawing in Inkscape just as we do. If you find some-
thing that could be improved, or needs to be updated, or have any other suggestions
concerning this book, we’d be happy to have you join us at our collaboration space at
gitlab.com or on Inkscape’s documentation mailing list

These are the people who contributed to this book:

• Jabiertxo Arraiza Cenoz

• Elisa de Castro Guerra

• Hinerangi Courtenay

• Sylvain Chiron

• Sergio González Collado

• Maren Hachmann

• Bernd Kampe

• Rosalind Lord

• JP Otto

• Jon Peyer

• Damien Picard

• David Milkes

• Christopher Michael Rogers
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• Carl Symons

• Reidar Vik

• Marietta Walker

• Help us improve this guide! Then you will find your own name in this list :-)
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SEVENTY

SAMPLE CHAPTER TITLE (H1)

This documentation uses ‘reStructured Text’ (reST) as its markup language. The below
document outlines most of the elements used in this guide.

If you have never used reST before, please familiarize yourself with its syntax (links
to cheatsheets below), or diligently copy-paste what you see here or in other parts of
the documentation. Note that spaces (and how many there are) are always relevant.
Without them, the automatical document creator does not understand what you mean,
and may give unexpected results. Backticks (this one: `, not apostrophes: ‘) are used
frequently in delimiting different elements.

70.1 Second level heading (h2)

It’s best to have this document opened as the finished web page, and as the source
text in parallel. That way you can see the syntax, and how it will look when the
documentation has been auto-created.

This is text in a paragraph. Separate paragraphs by an empty line. This is printed bold,
and this is in italics. This is for code and other small commandline commands that are
used inline.

70.1.1 Third level heading (h3)

Links to cheatsheets in a list:

• Structure Overview

• Paragraph Level Markup Overview

• Lists & Tables Overview

229

https://raw.githubusercontent.com/rtfd/sphinx_rtd_theme/master/docs/demo/structure.rst
https://raw.githubusercontent.com/rtfd/sphinx_rtd_theme/master/docs/demo/demo.rst
https://raw.githubusercontent.com/rtfd/sphinx_rtd_theme/master/docs/demo/lists_tables.rst


, Release 1.0

Fourth level heading (h4)

A numbered list with useful links:

1. Inkscape Website

This is a paragraph in a list

2. An internal link to another book chapter uses its file name (without the ‘.rst’):
Link to 3D Boxes

3. If you want to link to another section in this manual (this can be in any file, or in
this one), you must put a so called label there (with underscore).

1. Then you write the link to that label (no underscore) here.

1. If you want to refer to a section that starts with a heading, you do not need to use
a label. You can just directly refer to it like this: Third level heading (h3).

2. A download link, e.g. for an example file that users can play with, will look like
this: Link to Glyph A file

Images can be used within a sentence or line, or as a larger image with a description.

An image within a sentence can be something like this icon . You decide on a name
for the image that you put into the text. Then, you specify its properties in a separate
block. It’s best to put these blocks at the bottom of the document (scroll down to the
end to see it). This type of image can be described as an ‘inline image’.

All images that show a part of the Inkscape interface should be formatted like this and
have the class ‘screenshot’, a caption and an alt attribute. Screenshots should be in the
png file format and the relevant area should be as large as possible:

Images that are used for mere decoration look like this. You can use png images. If you
want to use an SVG image, you must also provide a pdf with the same content and give
it the same name. Then, you would need to replace the file extension by an asterisk in
the page source.
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Fig. 1: This is a caption for the image. Text should wrap around the caption. You can
add a ‘target’ line above, if you want to link to something.

Fig. 2: You can also use a two-column container, and the figures . . .
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Fig. 3: . . . will fit on one or two columns, depending on the display width.
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Available classes:

• for alignment: left, center, right

• for size: small, medium, large

If you want to tell the user how to get somewhere using the menu, use the menu
selection markup, e.g. Edit → Preferences → Input/Output → Autosave

For a label in the interface, use the gui label markup, e.g. Enable gradient editing.

If you want to tell the user which key to press, use the keyboard shortcut markup, e.g.
Ctrl + C.

For referencing a specific file on the user’s computer, use the markup for files, e.g.
~/.config/inkscape/preferences.xml

If you need to quote someone, or another document, do this by indenting by 4 spaces:

Inkscape is professional quality vector graphics software which runs on Win-
dows, Mac OS X and GNU/Linux. It is used by design professionals and
hobbyists worldwide, for creating a wide variety of graphics such as illus-
trations, icons, logos, diagrams, maps and web graphics. Inkscape uses the
W3C open standard SVG (Scalable Vector Graphics) as its native format,
and is free and open-source software.

—Inkscape Website

We can have different styles of admonition boxes:
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Attention: Watch out for this!

Caution: Be careful!

Warning: Drawing can be addictive.

Danger: Don’t break Inkscape!

Error: Now you have it.

Hint: The status line in Inkscape is very useful.

Important:

• Start your computer.

• Login.

• Start Inkscape.

• Select the rectangle tool.

Tip: Give the user a tip to have an easier time

with
things
in
Inkscape

Note: This is a note. You can add more contents below. Really.

And, by the way. . .
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You can make up your own admonitions titles, too. However, you cannot choose their
color.

Referring to terms in the glossary is a good way to help users have quick access to the
help they need, e.g. you can use Path: (if you want to keep the exact spelling) or path
(if you want to change the spelling, e.g. for plural, or to not use capitalization).

In case you ever want to put in a longer code block:

1 sudo apt-get install inkscape
2 flatpak install inkscape
3 snap install inkscape

Dashes and other typography:

Please follow English typography guidelines for dashes. See https://en.wikipedia.org/
wiki/Dash

En dash: –

Em dash: —

Ellipsis: . . .

We have inline formatting enabled to accommodate writing systems without spaces (e.g.
Chinese, Japanese and Korean systems), so please keep in mind that some characters
need to be escaped, namely underscores (_), asterisks (*) and pipe (|) characters. For
example, if you want to use a literal asterisk in math equations:

Attention: In the Align and Distribute dialog, there are 2 rows with 6 alignment
options in a row, which makes 6*2=12 alignment options in total.

In the example above, you should type 6\*2=12 to preserve the asterisk. Note that you
only need to escape these characters when there is no surrounding markup. For code
blocks and markup in the format :<markup>:`text`, there is no need to escape them.

1 Long code blocks like this one do not need character
2 escaping: _ * |. Other types of text blocks all require
3 escaping.

The following won’t be visible in this location, but it will appear in any place where you
write its ‘anchor’. Use the asterisk instead of the file ending, if there is both an svg and
a pdf of the image file available. This should be the case for all icons of the Inkscape
interface, as there is a complete set of them in the icons directory:
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